aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-02-10 05:25:26 +0800
committermiwi <miwi@FreeBSD.org>2009-02-10 05:25:26 +0800
commitd3ef1caa6fd747f2446a111057673a69f4d377c2 (patch)
tree18a593b7ed336410ee6b018ed2186d34f61c2412 /security
parent57b344793e5f664cd232904c5e2ea28b8765d32f (diff)
downloadfreebsd-ports-gnome-d3ef1caa6fd747f2446a111057673a69f4d377c2.tar.gz
freebsd-ports-gnome-d3ef1caa6fd747f2446a111057673a69f4d377c2.tar.zst
freebsd-ports-gnome-d3ef1caa6fd747f2446a111057673a69f4d377c2.zip
py-PF is a pure-Python module for managing OpenBSD's Packet Filter. It aims
to combine the flexibility of PF's C API and the power of Python, making it easier to manage PF data and to integrate firewalling capabilities in more complex applications. WWW: http://www.kernel-panic.it/software/py-pf/ PR: ports/131463 Submitted by: Sofian Brabez <sbrabez at gmail.com>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-PF/Makefile31
-rw-r--r--security/py-PF/distinfo3
-rw-r--r--security/py-PF/files/pkg-message.in8
-rw-r--r--security/py-PF/pkg-descr6
-rw-r--r--security/py-PF/pkg-plist25
6 files changed, 74 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 6f588ebf2576..5062ffba885b 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -633,6 +633,7 @@
SUBDIR += pwman
SUBDIR += pwman3
SUBDIR += pxytest
+ SUBDIR += py-PF
SUBDIR += py-bcrypt
SUBDIR += py-cerealizer
SUBDIR += py-clamav
diff --git a/security/py-PF/Makefile b/security/py-PF/Makefile
new file mode 100644
index 000000000000..7a308a42ea6a
--- /dev/null
+++ b/security/py-PF/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: py-PF
+# Date created: 2009-02-07
+# Whom: Sofian Brabez <sbrabez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PF
+PORTVERSION= 0.0.2
+CATEGORIES= security python
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PYTHON_PKGNAMEPREFIX:C/[0-9]+//}${PORTNAME:L}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PYTHON_PKGNAMEPREFIX:C/[0-9]+//}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= sbrabez@gmail.com
+COMMENT= A pure-Python module for managing OpenBSD Packet Filter
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= ${PYTHON_PKGNAMEPREFIX:C/[0-9]+//}_${PORTNAME}
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/py-PF/distinfo b/security/py-PF/distinfo
new file mode 100644
index 000000000000..74272299032d
--- /dev/null
+++ b/security/py-PF/distinfo
@@ -0,0 +1,3 @@
+MD5 (py-PF-0.0.2.tar.gz) = e595b0783180efb1c72ab87d9e5d0d16
+SHA256 (py-PF-0.0.2.tar.gz) = 978a2da9000985eb154c1e62efd7f864564514780cb0a55fe2ca0d798a7c5af1
+SIZE (py-PF-0.0.2.tar.gz) = 24066
diff --git a/security/py-PF/files/pkg-message.in b/security/py-PF/files/pkg-message.in
new file mode 100644
index 000000000000..d1278f15401d
--- /dev/null
+++ b/security/py-PF/files/pkg-message.in
@@ -0,0 +1,8 @@
+-------------------------------------------------------------
+py-pF is installed.
+
+For a quick start:
+ - import PF for using this module
+ - read http://www.kernel-panic.it/programming/py-pf/
+ - you need to be root for using this module
+-------------------------------------------------------------
diff --git a/security/py-PF/pkg-descr b/security/py-PF/pkg-descr
new file mode 100644
index 000000000000..859d583bb7cc
--- /dev/null
+++ b/security/py-PF/pkg-descr
@@ -0,0 +1,6 @@
+py-PF is a pure-Python module for managing OpenBSD's Packet Filter. It aims
+to combine the flexibility of PF's C API and the power of Python, making it
+easier to manage PF data and to integrate firewalling capabilities in more
+complex applications.
+
+WWW: http://www.kernel-panic.it/software/py-pf/
diff --git a/security/py-PF/pkg-plist b/security/py-PF/pkg-plist
new file mode 100644
index 000000000000..65494bd3887f
--- /dev/null
+++ b/security/py-PF/pkg-plist
@@ -0,0 +1,25 @@
+%%PYTHON_SITELIBDIR%%/PF/PFConstants.py
+%%PYTHON_SITELIBDIR%%/PF/PFConstants.pyc
+%%PYTHON_SITELIBDIR%%/PF/PFConstants.pyo
+%%PYTHON_SITELIBDIR%%/PF/PFRule.py
+%%PYTHON_SITELIBDIR%%/PF/PFRule.pyc
+%%PYTHON_SITELIBDIR%%/PF/PFRule.pyo
+%%PYTHON_SITELIBDIR%%/PF/PFState.py
+%%PYTHON_SITELIBDIR%%/PF/PFState.pyc
+%%PYTHON_SITELIBDIR%%/PF/PFState.pyo
+%%PYTHON_SITELIBDIR%%/PF/PFStatus.py
+%%PYTHON_SITELIBDIR%%/PF/PFStatus.pyc
+%%PYTHON_SITELIBDIR%%/PF/PFStatus.pyo
+%%PYTHON_SITELIBDIR%%/PF/PFUtils.py
+%%PYTHON_SITELIBDIR%%/PF/PFUtils.pyc
+%%PYTHON_SITELIBDIR%%/PF/PFUtils.pyo
+%%PYTHON_SITELIBDIR%%/PF/PacketFilter.py
+%%PYTHON_SITELIBDIR%%/PF/PacketFilter.pyc
+%%PYTHON_SITELIBDIR%%/PF/PacketFilter.pyo
+%%PYTHON_SITELIBDIR%%/PF/_PFStruct.py
+%%PYTHON_SITELIBDIR%%/PF/_PFStruct.pyc
+%%PYTHON_SITELIBDIR%%/PF/_PFStruct.pyo
+%%PYTHON_SITELIBDIR%%/PF/__init__.py
+%%PYTHON_SITELIBDIR%%/PF/__init__.pyc
+%%PYTHON_SITELIBDIR%%/PF/__init__.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/PF