aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2006-03-17 05:40:45 +0800
committermnag <mnag@FreeBSD.org>2006-03-17 05:40:45 +0800
commitdd575ae7a4844cd324585bab65254f4419face04 (patch)
tree955fc8abcb2637fc9e28dfd5ad16271fc366c253 /security
parentfeb378def91eec4b4a50a6f6d03794c34d9041fc (diff)
downloadfreebsd-ports-gnome-dd575ae7a4844cd324585bab65254f4419face04.tar.gz
freebsd-ports-gnome-dd575ae7a4844cd324585bab65254f4419face04.tar.zst
freebsd-ports-gnome-dd575ae7a4844cd324585bab65254f4419face04.zip
- Add port security/pecl-gnupg
This extension provides methods to PHP interact with gnupg. WWW: http://pecl.php.net/package/gnupg
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pecl-gnupg/Makefile53
-rw-r--r--security/pecl-gnupg/distinfo3
-rw-r--r--security/pecl-gnupg/pkg-descr3
4 files changed, 60 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e017dd2ab277..52f1ef9e392c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -451,6 +451,7 @@
SUBDIR += pear-LiveUser_Admin
SUBDIR += pear-Text_Password
SUBDIR += pecl-filter
+ SUBDIR += pecl-gnupg
SUBDIR += pecl-hash
SUBDIR += pecl-ssh2
SUBDIR += pft
diff --git a/security/pecl-gnupg/Makefile b/security/pecl-gnupg/Makefile
new file mode 100644
index 000000000000..d7e345233d56
--- /dev/null
+++ b/security/pecl-gnupg/Makefile
@@ -0,0 +1,53 @@
+# Ports collection makefile for: pear-gnupg
+# Date created: 16 March 2006
+# Whom: mnag@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnupg
+PORTVERSION= 1.1
+CATEGORIES= security
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= mnag@FreeBSD.org
+COMMENT= A pecl wrapper around the gpgme library
+
+LIB_DEPENDS= gpgme.15:${PORTSDIR}/security/gpgme
+
+USE_PHP= yes
+USE_PHPEXT= yes
+PHP_MODNAME= gnupg
+
+CONFIGURE_ARGS= --with-gnupg=${LOCALBASE}/include/gpgme
+CFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+
+PLIST_FILES= %%EXAMPLESDIR%%/clearsign.php %%EXAMPLESDIR%%/decrypt.php \
+ %%EXAMPLESDIR%%/encrypt.php %%EXAMPLESDIR%%/encryptsign.php \
+ %%EXAMPLESDIR%%/export.php %%EXAMPLESDIR%%/import.php \
+ %%EXAMPLESDIR%%/keyinfo.php %%EXAMPLESDIR%%/main.php \
+ %%EXAMPLESDIR%%/verify.php
+PLIST_DIRS= %%EXAMPLESDIR%%
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000 && ${PHP_VER} == 5
+USE_GCC= 3.2+
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|\$$GNUPG_DIR/include|${LOCALBASE}/include/gpgme|" \
+ -e "s|\$$GNUPG_DIR/lib|${LOCALBASE}/lib|" -e "s|-ldl||g" \
+ ${WRKSRC}/config.m4
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.php ${EXAMPLESDIR}
+
+.include <bsd.port.post.mk>
diff --git a/security/pecl-gnupg/distinfo b/security/pecl-gnupg/distinfo
new file mode 100644
index 000000000000..44967f438709
--- /dev/null
+++ b/security/pecl-gnupg/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/gnupg-1.1.tgz) = 6c7e2f287f9666366ca482ee1a81ad2e
+SHA256 (PECL/gnupg-1.1.tgz) = 198c2a04e7c7d6ef8cd6ffa82c0e370fc6af233e17c07289c3b030c2406d82ff
+SIZE (PECL/gnupg-1.1.tgz) = 17518
diff --git a/security/pecl-gnupg/pkg-descr b/security/pecl-gnupg/pkg-descr
new file mode 100644
index 000000000000..cf0a4dcf575a
--- /dev/null
+++ b/security/pecl-gnupg/pkg-descr
@@ -0,0 +1,3 @@
+This extension provides methods to PHP interact with gnupg.
+
+WWW: http://pecl.php.net/package/gnupg