aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2014-07-25 03:43:59 +0800
committerbdrewery <bdrewery@FreeBSD.org>2014-07-25 03:43:59 +0800
commitedf0bbe2a6cd5a6f5a6691319fb7baaf2883992e (patch)
treeec06cf3d8bb656129bf89024a2aa51d7486f7c0b /security
parentecd04e5be5ede1e49a0e8d1e2cf4b86d9e7a9982 (diff)
downloadfreebsd-ports-gnome-edf0bbe2a6cd5a6f5a6691319fb7baaf2883992e.tar.gz
freebsd-ports-gnome-edf0bbe2a6cd5a6f5a6691319fb7baaf2883992e.tar.zst
freebsd-ports-gnome-edf0bbe2a6cd5a6f5a6691319fb7baaf2883992e.zip
Update to 3.2.16
Diffstat (limited to 'security')
-rw-r--r--security/gnutls/Makefile3
-rw-r--r--security/gnutls/distinfo4
-rw-r--r--security/gnutls/files/patch-lib__x509__rfc2818_hostname.c10
3 files changed, 14 insertions, 3 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 4df5ade03f0e..fb7a30b6eebf 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= gnutls
-PORTVERSION= 3.2.15
+PORTVERSION= 3.2.16
CATEGORIES= security net
MASTER_SITES= GNUPG/gnutls/v3.2
@@ -47,5 +47,6 @@ post-patch:
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/doc/examples/*.[ch] ${STAGEDIR}${EXAMPLESDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgnutls*.so.*
.include <bsd.port.mk>
diff --git a/security/gnutls/distinfo b/security/gnutls/distinfo
index 24ca8ed3bf38..e4f4c7a26875 100644
--- a/security/gnutls/distinfo
+++ b/security/gnutls/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnutls-3.2.15.tar.xz) = 30bdc7b34b220258f714602cdf0afa1abf0883bf926f35f400c88b1c72ca77b9
-SIZE (gnutls-3.2.15.tar.xz) = 5140200
+SHA256 (gnutls-3.2.16.tar.xz) = 781836a04a8bbb42e6590d6524d53c870850d26fc55146a7e0e5d7e1d183bcae
+SIZE (gnutls-3.2.16.tar.xz) = 5337140
diff --git a/security/gnutls/files/patch-lib__x509__rfc2818_hostname.c b/security/gnutls/files/patch-lib__x509__rfc2818_hostname.c
new file mode 100644
index 000000000000..3db16eb9588a
--- /dev/null
+++ b/security/gnutls/files/patch-lib__x509__rfc2818_hostname.c
@@ -0,0 +1,10 @@
+--- ./lib/x509/rfc2818_hostname.c.orig 2014-07-24 14:38:24.963183389 -0500
++++ ./lib/x509/rfc2818_hostname.c 2014-07-24 14:38:55.151183492 -0500
+@@ -25,6 +25,7 @@
+ #include <common.h>
+ #include <gnutls_errors.h>
+ #include <arpa/inet.h>
++#include <netinet/in.h>
+
+ static int
+ check_ip(gnutls_x509_crt_t cert, const void *ip, unsigned ip_size)