aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2009-10-06 01:03:28 +0800
committerjohans <johans@FreeBSD.org>2009-10-06 01:03:28 +0800
commitf23e5d4447c6dde0099e0a5bf97e1836396d7b66 (patch)
tree6111744356796c340cca8f8b33ec33f1b1453386 /security
parentd2d705274ef5ab0cb125445354b67d0d9420c2a8 (diff)
downloadfreebsd-ports-gnome-f23e5d4447c6dde0099e0a5bf97e1836396d7b66.tar.gz
freebsd-ports-gnome-f23e5d4447c6dde0099e0a5bf97e1836396d7b66.tar.zst
freebsd-ports-gnome-f23e5d4447c6dde0099e0a5bf97e1836396d7b66.zip
Fix build with GNUTLS option (auto-detection failed)
Diffstat (limited to 'security')
-rw-r--r--security/xmlsec1/Makefile22
1 files changed, 15 insertions, 7 deletions
diff --git a/security/xmlsec1/Makefile b/security/xmlsec1/Makefile
index 6c0ba0edeafd..0b7ab6f56fec 100644
--- a/security/xmlsec1/Makefile
+++ b/security/xmlsec1/Makefile
@@ -63,6 +63,13 @@ LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --without-gnutls
.endif
+.if defined(WITH_NSS)
+CONFIGURE_ARGS+= --with-nss="${LOCALBASE}" --with-nspr="${LOCALBASE}"
+LIB_DEPENDS+= nss3:${PORTSDIR}/security/nss
+.else
+CONFIGURE_ARGS+= --without-nss
+.endif
+
CONFIGURE_ARGS+= --with-openssl="${OPENSSLBASE}"
post-patch:
@@ -85,16 +92,17 @@ post-patch:
@${REINPLACE_CMD} \
-e 's,total_time.*/ 1000),total_time*1000/CLOCKS_PER_SEC,' \
${WRKSRC}/apps/xmlsec.c
+.if defined(WITH_GNUTLS)
+# Don't rely on broken autodetection
+ @${REINPLACE_CMD} -e '/^GNUTLS_FOUND/s/no/yes/' \
+ -e '/^GNUTLS_LIBS=/s,"","-L${LOCALBASE}/lib -lgnutls",' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
.if defined(WITH_NSS)
- # Makeing the xmlsec1 executable multi-threaded to let load -lnss,
- # when needed.
+# Makeing the xmlsec1 executable multi-threaded to let load -lnss,
+# when needed.
@${REINPLACE_CMD} -e 's,^\(xmlsec1_LDADD = \)\\$$,\1 -L${LOCALBASE}/lib ${PTHREAD_LIBS}\\,' \
${WRKSRC}/apps/Makefile.in
-
-CONFIGURE_ARGS+= --with-nss="${LOCALBASE}" --with-nspr="${LOCALBASE}"
-LIB_DEPENDS+= nss3:${PORTSDIR}/security/nss
-.else
-CONFIGURE_ARGS+= --without-nss
.endif
.include <bsd.port.post.mk>