aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-01-31 13:53:55 +0800
committerdinoex <dinoex@FreeBSD.org>2003-01-31 13:53:55 +0800
commitf4e8db7343b5ef4c109d4446bfe0c20724358457 (patch)
treebaf8d84c1ca83e373d6ef6ed954555d199c59f58 /security
parentc7447b94a416bab6cdfc6a27f4e50f14b500e066 (diff)
downloadfreebsd-ports-gnome-f4e8db7343b5ef4c109d4446bfe0c20724358457.tar.gz
freebsd-ports-gnome-f4e8db7343b5ef4c109d4446bfe0c20724358457.tar.zst
freebsd-ports-gnome-f4e8db7343b5ef4c109d4446bfe0c20724358457.zip
- break build, when port try to pick up the wrong shared lib.
Diffstat (limited to 'security')
-rw-r--r--security/openssl/Makefile.ssl8
1 files changed, 8 insertions, 0 deletions
diff --git a/security/openssl/Makefile.ssl b/security/openssl/Makefile.ssl
index 643704f89b83..fa775e034068 100644
--- a/security/openssl/Makefile.ssl
+++ b/security/openssl/Makefile.ssl
@@ -19,6 +19,14 @@ OPENSSLDIR= /etc/ssl
@${ECHO_CMD} "OpenSSL distribution."
@${FALSE}
.endif
+.if exists(${LOCALBASE}/lib/libcrypto.so)
+.BEGIN:
+ @${ECHO_CMD} "This port wants the OpenSSL library from the FreeBSD"
+ @${ECHO_CMD} "base system. You can't build against it, while a newer"
+ @${ECHO_CMD} "Version is installed by a port."
+ @${ECHO_CMD} "Please deinstall the port or undefine USE_OPENSSL_BASE."
+ @${FALSE}
+.endif
# OpenSSL in the base system may not include IDEA for patent licensing reasons.
.if defined(MAKE_IDEA) && !defined(OPENSSL_IDEA)