aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-11 13:00:56 +0800
committermarino <marino@FreeBSD.org>2016-09-11 13:00:56 +0800
commitf7697154b73d4fd146bd64149c12a6fee0169847 (patch)
tree409d0638e0b23bb34106493f287275f3273650f9 /security
parent2261b8e55d45cbb9397bbbb200db3166ee731090 (diff)
downloadfreebsd-ports-gnome-f7697154b73d4fd146bd64149c12a6fee0169847.tar.gz
freebsd-ports-gnome-f7697154b73d4fd146bd64149c12a6fee0169847.tar.zst
freebsd-ports-gnome-f7697154b73d4fd146bd64149c12a6fee0169847.zip
security/ratproxy: Add SSL flags and honor them
Approved by: SSL blanket
Diffstat (limited to 'security')
-rw-r--r--security/ratproxy/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/security/ratproxy/Makefile b/security/ratproxy/Makefile
index ae1a4ee634da..a8ef607eb5c9 100644
--- a/security/ratproxy/Makefile
+++ b/security/ratproxy/Makefile
@@ -9,8 +9,9 @@ MASTER_SITES= GOOGLE_CODE
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Semi-automated, largely passive web application security audit tool
-USES= shebangfix
-USE_OPENSSL= YES
+USES= shebangfix ssl
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -19,7 +20,8 @@ PLIST_FILES= bin/ratproxy \
bin/ratproxy-report.sh
post-patch:
- @${REINPLACE_CMD} -e 's#-Wno-pointer-sign##g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's#-Wno-pointer-sign##g' \
+ -e "s|\(-lcrypto\)|${LDFLAGS} \1|g" ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ratproxy ${STAGEDIR}${PREFIX}/bin