aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-12-17 23:00:26 +0800
committerpawel <pawel@FreeBSD.org>2012-12-17 23:00:26 +0800
commitfeaf58fc043ea72056be1dc2e6d7359998779798 (patch)
treed57b29072a2b867940da1a695afa3acc7e9fe5cb /security
parent96e176b332f25ad0ac1d793f40abcdca73c2c897 (diff)
downloadfreebsd-ports-gnome-feaf58fc043ea72056be1dc2e6d7359998779798.tar.gz
freebsd-ports-gnome-feaf58fc043ea72056be1dc2e6d7359998779798.tar.zst
freebsd-ports-gnome-feaf58fc043ea72056be1dc2e6d7359998779798.zip
This PAM service module allows PAM-enabled applications to check if
the target user is in some arbitrary plaintext list. Similar to module pam_ftpusers from the FreeBSD Project and is based on it's code. WWW: http://sourceforge.net/projects/pam-search-list/ PR: ports/169877 Submitted by: Victor Popov
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pam_search_list/Makefile23
-rw-r--r--security/pam_search_list/distinfo2
-rw-r--r--security/pam_search_list/pkg-descr5
4 files changed, 31 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index b8198a6efdb2..b691755efb3c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -611,6 +611,7 @@
SUBDIR += pam_pseudo
SUBDIR += pam_pwdfile
SUBDIR += pam_require
+ SUBDIR += pam_search_list
SUBDIR += pam_smb
SUBDIR += pam_ssh_agent_auth
SUBDIR += pamtester
diff --git a/security/pam_search_list/Makefile b/security/pam_search_list/Makefile
new file mode 100644
index 000000000000..debe90394929
--- /dev/null
+++ b/security/pam_search_list/Makefile
@@ -0,0 +1,23 @@
+# Created by: Victor Popov
+# $FreeBSD$
+
+PORTNAME= pam_search_list
+PORTVERSION= 0.1
+CATEGORIES= security
+MASTER_SITES= SF/${PORTNAME:S/_/-/g}
+DISTNAME= ${PORTNAME:S/_/-/g}-${PORTVERSION}
+
+MAINTAINER= v.a.popov@gmail.com
+COMMENT= PAM module to search arbitrary file for user
+
+USE_XZ= yes
+
+MANCOMPRESSED= yes
+MAN8= pam_search_list.8
+
+PLIST_FILES= lib/libpam_search_list.a \
+ lib/libpam_search_list_p.a \
+ lib/pam_search_list.so \
+ lib/pam_search_list.so.0
+
+.include <bsd.port.mk>
diff --git a/security/pam_search_list/distinfo b/security/pam_search_list/distinfo
new file mode 100644
index 000000000000..61441a9ec1b3
--- /dev/null
+++ b/security/pam_search_list/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pam-search-list-0.1.tar.xz) = 77009f307e00413239a4cde497257b0ec33c1fd5c9879461174303230a44c417
+SIZE (pam-search-list-0.1.tar.xz) = 3184
diff --git a/security/pam_search_list/pkg-descr b/security/pam_search_list/pkg-descr
new file mode 100644
index 000000000000..fcaee2eae3c2
--- /dev/null
+++ b/security/pam_search_list/pkg-descr
@@ -0,0 +1,5 @@
+This PAM service module allows PAM-enabled applications to check if
+the target user is in some arbitrary plaintext list. Similar to module
+pam_ftpusers from the FreeBSD Project and is based on it's code.
+
+WWW: http://sourceforge.net/projects/pam-search-list/