aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-07-28 07:04:48 +0800
committershaun <shaun@FreeBSD.org>2006-07-28 07:04:48 +0800
commit061232007f0a8728d275c33f138a36fe5c2ffbe1 (patch)
tree972b86518785b8fc902130f14fc6df08c053bcf7 /security
parent86c187087c3b3f2fdd8ef6e114c7077e69a728e8 (diff)
downloadfreebsd-ports-gnome-061232007f0a8728d275c33f138a36fe5c2ffbe1.tar.gz
freebsd-ports-gnome-061232007f0a8728d275c33f138a36fe5c2ffbe1.tar.zst
freebsd-ports-gnome-061232007f0a8728d275c33f138a36fe5c2ffbe1.zip
- Fix build on 64-bit machines.
- Mark IGNORE on !i386, due to a run-time issue. - Use DATADIR macro in pkg-plist while here. PR: ports/99949 Submitted by: shaun (me) Approved by: Maintainer timeout (19 days)
Diffstat (limited to 'security')
-rw-r--r--security/sfs/Makefile2
-rw-r--r--security/sfs/files/patch-async_itree.h11
-rw-r--r--security/sfs/pkg-plist14
3 files changed, 19 insertions, 8 deletions
diff --git a/security/sfs/Makefile b/security/sfs/Makefile
index 32ab0c8feaca..f20bd6da6dcb 100644
--- a/security/sfs/Makefile
+++ b/security/sfs/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ARGS+=--with-sfsuser=sfs \
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
+IGNORE= nfsmounter component fails execute correctly on ${ARCH} systems
.endif
.if ${OSVERSION} > 500000
diff --git a/security/sfs/files/patch-async_itree.h b/security/sfs/files/patch-async_itree.h
new file mode 100644
index 000000000000..b457b22656f6
--- /dev/null
+++ b/security/sfs/files/patch-async_itree.h
@@ -0,0 +1,11 @@
+--- async/itree.h.orig Sun Jul 9 00:14:16 2006
++++ async/itree.h Sun Jul 9 00:15:07 2006
+@@ -86,7 +86,7 @@
+ itree_core (const itree_core &);
+ itree_core &operator = (const itree_core &);
+
+-#define eos ((int) &(((T *) 0)->*field).p)
++#define eos ((ptrdiff_t) &(((T *) 0)->*field).p)
+ #define cmpfn scmp, (void *) this
+
+ public:
diff --git a/security/sfs/pkg-plist b/security/sfs/pkg-plist
index c0371dd9686f..6aea3be4f8ad 100644
--- a/security/sfs/pkg-plist
+++ b/security/sfs/pkg-plist
@@ -173,11 +173,11 @@ sbin/vidb
%%DOCSDIR%%/README.packageblurb
%%DOCSDIR%%/README.0.7-upgrade
@dirrm %%DOCSDIR%%
-share/sfs/agentrc
-share/sfs/sfs_config
-share/sfs/sfs_srp_parms
-share/sfs/sfsauthd_config
-share/sfs/sfscd_config
-share/sfs/sfssd_config
-@dirrm share/sfs
+%%DATADIR%%/agentrc
+%%DATADIR%%/sfs_config
+%%DATADIR%%/sfs_srp_parms
+%%DATADIR%%/sfsauthd_config
+%%DATADIR%%/sfscd_config
+%%DATADIR%%/sfssd_config
+@dirrm %%DATADIR%%
@dirrm etc/sfs