aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-12-09 21:12:12 +0800
committerantoine <antoine@FreeBSD.org>2017-12-09 21:12:12 +0800
commit09c6f9094f9c760773a4c04cface8bae5b89841f (patch)
tree225d67d01f6a231f4a64a734ad3f12ef0fe1a178 /security
parent68a312aad6652f5220ea37f676926808f377d83d (diff)
downloadfreebsd-ports-gnome-09c6f9094f9c760773a4c04cface8bae5b89841f.tar.gz
freebsd-ports-gnome-09c6f9094f9c760773a4c04cface8bae5b89841f.tar.zst
freebsd-ports-gnome-09c6f9094f9c760773a4c04cface8bae5b89841f.zip
- hotssh doesn't work with python3
- add explicit FLAVOR to dependencies (useful when using DEFAULT_VERSIONS=python=3.x) - fix shebang
Diffstat (limited to 'security')
-rw-r--r--security/hotssh/Makefile24
1 files changed, 11 insertions, 13 deletions
diff --git a/security/hotssh/Makefile b/security/hotssh/Makefile
index 0ea8aeb1d750..b311fc174fc6 100644
--- a/security/hotssh/Makefile
+++ b/security/hotssh/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hotssh
PORTVERSION= 0.2.7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= security gnome
MASTER_SITES= GNOME
@@ -13,18 +13,16 @@ COMMENT= HotSSH is an interface to Secure Shell, for GNOME and OpenSSH
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus \
- ${LOCALBASE}/libdata/pkgconfig/pygobject-2.0.pc:devel/py-gobject \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc:devel/dbus-glib \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
- ${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:x11-toolkits/py-vte
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus \
- ${LOCALBASE}/libdata/pkgconfig/pygobject-2.0.pc:devel/py-gobject \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
- ${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:x11-toolkits/py-vte
-
-USE_GNOME= pygtk2 gnomedocutils libxslt glib20 intltool
-USES= gettext python tar:bzip2 waf
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}vte>=0:x11-toolkits/py-vte@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}vte>=0:x11-toolkits/py-vte@${PY_FLAVOR}
+
+USE_GNOME= glib20 gnomedocutils intltool libxslt pygobject pygtk2
+USES= gettext python:2.7 tar:bzip2 waf
INSTALLS_ICONS= yes
NO_ARCH= yes
@@ -32,7 +30,7 @@ B64DECODE?= /usr/bin/b64decode
BSPATCH?= /usr/bin/bspatch
post-extract:
- @${GREP} -Rl '^#!/usr/bin/python$$' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -e 's|^#!/usr/bin/python$$|#!/usr/bin/env python|g'
+ @${GREP} -Rl '^#!/usr/bin/python$$' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -e 's|^#!/usr/bin/python$$|#!${PYTHON_CMD}|g'
@${MV} ${WRKSRC}/waf ${WRKSRC}/waf.beforepatch
@cd ${WRKSRC} && ${B64DECODE} -o waf.diff ${FILESDIR}/waf.diff && ${BSPATCH} waf.beforepatch waf waf.diff && ${CHMOD} 755 waf
@${GREP} -Rl '%%LOCALBASE%%' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g"