aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorniels <niels@FreeBSD.org>2010-03-09 06:03:20 +0800
committerniels <niels@FreeBSD.org>2010-03-09 06:03:20 +0800
commit10f06ff6a31aeaa418553e616996fc37e431983a (patch)
treebdc48f1ae4209dd39bf3c90c983bc6ed4293c186 /security
parent32b63e24e284261c8d3168fae55db5a5e52b614f (diff)
downloadfreebsd-ports-gnome-10f06ff6a31aeaa418553e616996fc37e431983a.tar.gz
freebsd-ports-gnome-10f06ff6a31aeaa418553e616996fc37e431983a.tar.zst
freebsd-ports-gnome-10f06ff6a31aeaa418553e616996fc37e431983a.zip
Burp Suite is an integrated platform for testing web applications
PR: ports/144150 Submitted by: niels Approved by: itetcu (mentor) WWW: http://www.portswigger.net/suite/
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/burpsuite/Makefile50
-rw-r--r--security/burpsuite/distinfo3
-rw-r--r--security/burpsuite/files/burpsuite.sh7
-rw-r--r--security/burpsuite/pkg-descr7
5 files changed, 68 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 713749f980f5..361eb83e0510 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -50,6 +50,7 @@
SUBDIR += bsp_upektfmess
SUBDIR += bubblegum
SUBDIR += bugs
+ SUBDIR += burpsuite
SUBDIR += ca_root_nss
SUBDIR += calife
SUBDIR += calife-devel
diff --git a/security/burpsuite/Makefile b/security/burpsuite/Makefile
new file mode 100644
index 000000000000..3c24fc20c763
--- /dev/null
+++ b/security/burpsuite/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: Burpsuite
+# Date created: 2010-02-22
+# Whom: Niels Heinen
+#
+# $FreeBSD$
+#
+
+PORTNAME= burpsuite
+PORTVERSION= 1.3
+CATEGORIES= security java
+MASTER_SITES= http://www.portswigger.net/suite/
+DISTNAME= ${PORTNAME}_v${PORTVERSION}
+
+MAINTAINER= niels@FreeBSD.org
+COMMENT= Burp Suite is an integrated platform for testing web applications
+
+USE_ZIP= YES
+USE_JAVA= YES
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+PLIST_FILES= bin/${PORTNAME} %%JAVAJARDIR%%/${DISTNAME}.jar
+
+#.if !defined(NOPORTDOCS)
+PORTDOCS= readme_-_running_burp.txt terms_and_conditions.txt
+#.endif
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ ${MV} ${WRKSRC}/readme\ -\ running\ burp.txt ${WRKSRC}/readme_-_running_burp.txt
+ ${MV} ${WRKSRC}/terms\ and\ conditions.txt ${WRKSRC}/terms_and_conditions.txt
+
+pre-install:
+ @${SED} -e 's:%%PATH%%:${JAVAJARDIR}/:' \
+ -e 's:%%JAVA_CMD%%:${JAVA}:' \
+ -e 's:%%BURP%%:${JAVAJARDIR}/${DISTNAME}.jar:' \
+ < ${FILESDIR}/${PORTNAME}.sh > ${WRKDIR}/${PORTNAME}
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/${DISTNAME}.jar ${JAVAJARDIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme_-_running_burp.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/terms_and_conditions.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/burpsuite/distinfo b/security/burpsuite/distinfo
new file mode 100644
index 000000000000..a3f1f2906833
--- /dev/null
+++ b/security/burpsuite/distinfo
@@ -0,0 +1,3 @@
+MD5 (burpsuite_v1.3.zip) = 592004af60d77ee23fe4371a50eeb190
+SHA256 (burpsuite_v1.3.zip) = ccd421ee6d138346c3e5b117e98b3d89faa1a11fef5c54725bec99cb13765d2f
+SIZE (burpsuite_v1.3.zip) = 2530299
diff --git a/security/burpsuite/files/burpsuite.sh b/security/burpsuite/files/burpsuite.sh
new file mode 100644
index 000000000000..29cff364b72e
--- /dev/null
+++ b/security/burpsuite/files/burpsuite.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+cd %%PATH%%
+exec %%JAVA_CMD%% -jar -Xmx256m %%BURP%% "$@"
diff --git a/security/burpsuite/pkg-descr b/security/burpsuite/pkg-descr
new file mode 100644
index 000000000000..46bdb19f0f53
--- /dev/null
+++ b/security/burpsuite/pkg-descr
@@ -0,0 +1,7 @@
+Burp Suite is a closed source tool which allows you to combine
+manual and automated techniques to enumerate, analyse, scan, attack
+and exploit web applications. The various Burp tools work together
+effectively to share information and allow findings identified
+within one tool to form the basis of an attack using another.
+
+WWW: http://www.portswigger.net/suite/