aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2001-06-08 08:15:27 +0800
committerdwcjr <dwcjr@FreeBSD.org>2001-06-08 08:15:27 +0800
commit150641fc377f31b48aa7084638c6817f3f3fce75 (patch)
tree6824cce2409cf13a6fb7fc606a63df48170cd7b7 /security
parentfe45fd695dc751cca5fc22d1331b5a3cab1d7687 (diff)
downloadfreebsd-ports-gnome-150641fc377f31b48aa7084638c6817f3f3fce75.tar.gz
freebsd-ports-gnome-150641fc377f31b48aa7084638c6817f3f3fce75.tar.zst
freebsd-ports-gnome-150641fc377f31b48aa7084638c6817f3f3fce75.zip
Add ssldump, "An SSLv3/TLS network protocol analyzer"
PR: 27946 Submitted by: tacho@daemonz.org Reviewed by: will
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/ssldump/Makefile25
-rw-r--r--security/ssldump/distinfo2
-rw-r--r--security/ssldump/pkg-comment1
-rw-r--r--security/ssldump/pkg-descr10
-rw-r--r--security/ssldump/pkg-plist1
6 files changed, 40 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 00f2a3b92026..b82fae514419 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -156,6 +156,7 @@
SUBDIR += ssh
SUBDIR += ssh-multiadd
SUBDIR += ssh2
+ SUBDIR += ssldump
SUBDIR += sslproxy
SUBDIR += sslwrap
SUBDIR += sst
diff --git a/security/ssldump/Makefile b/security/ssldump/Makefile
new file mode 100644
index 000000000000..c0e536e0c6e7
--- /dev/null
+++ b/security/ssldump/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: ssldump
+# Date created: 07 Jun 2001
+# Whom: Stanislav Grozev <tacho@daemonz.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssldump
+PORTVERSION= 0.9b1.p1
+CATEGORIES= security
+MASTER_SITES= http://www.rtfm.com/ssldump/
+DISTNAME= ssldump-0.9b1
+DIST_SUBDIR= ssldump
+
+PATCH_SITES= http://www.rtfm.com/ssldump/
+PATCHFILES= patch1
+
+MAINTAINER= tacho@daemonz.org
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-openssl=/usr
+
+MAN1= ssldump.1
+
+.include <bsd.port.mk>
diff --git a/security/ssldump/distinfo b/security/ssldump/distinfo
new file mode 100644
index 000000000000..9f3982ee35f8
--- /dev/null
+++ b/security/ssldump/distinfo
@@ -0,0 +1,2 @@
+MD5 (ssldump/ssldump-0.9b1.tar.gz) = ace8f1b4f8bfa4cd494a3e546655c5e7
+MD5 (ssldump/patch1) = 799e5c2638639c5250b1937d706a7ddf
diff --git a/security/ssldump/pkg-comment b/security/ssldump/pkg-comment
new file mode 100644
index 000000000000..44ccf99232e3
--- /dev/null
+++ b/security/ssldump/pkg-comment
@@ -0,0 +1 @@
+An SSLv3/TLS network protocol analyzer
diff --git a/security/ssldump/pkg-descr b/security/ssldump/pkg-descr
new file mode 100644
index 000000000000..c834ad1cf265
--- /dev/null
+++ b/security/ssldump/pkg-descr
@@ -0,0 +1,10 @@
+ssldump is an SSLv3/TLS network protocol analyzer. It identifies TCP connections
+on the chosen network interface and attempts to interpret them as SSLv3/TLS
+traffic. When it identifies SSLv3/TLS traffic, it decodes the records and
+displays them in a textual form to stdout. If provided with the appropriate
+keying material, it will also decrypt the connections and display the
+application data traffic.
+
+WWW: http://www.rtfm.com/ssldump/
+
+-tacho@daemonz.org
diff --git a/security/ssldump/pkg-plist b/security/ssldump/pkg-plist
new file mode 100644
index 000000000000..dbb1bdc0d110
--- /dev/null
+++ b/security/ssldump/pkg-plist
@@ -0,0 +1 @@
+bin/ssldump