aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-05-23 10:19:02 +0800
committerjgh <jgh@FreeBSD.org>2013-05-23 10:19:02 +0800
commit197e34167f91933cdb8448cc7a7d995b760151d1 (patch)
tree7387196f77943048eba0c2b0e857984f08f2b4fc /security
parentda7602aef88e09c1333866d16a090d8fd9349d93 (diff)
downloadfreebsd-ports-gnome-197e34167f91933cdb8448cc7a7d995b760151d1.tar.gz
freebsd-ports-gnome-197e34167f91933cdb8448cc7a7d995b760151d1.tar.zst
freebsd-ports-gnome-197e34167f91933cdb8448cc7a7d995b760151d1.zip
- adoption of optionsNG
Approved by: portmgr (miwi)
Diffstat (limited to 'security')
-rw-r--r--security/courier-authlib/Makefile4
-rw-r--r--security/courier-authlib/Makefile.dep18
-rw-r--r--security/courier-authlib/Makefile.opt17
3 files changed, 16 insertions, 23 deletions
diff --git a/security/courier-authlib/Makefile b/security/courier-authlib/Makefile
index 7410ddd251cd..bfb6c2ab6ab6 100644
--- a/security/courier-authlib/Makefile
+++ b/security/courier-authlib/Makefile
@@ -28,7 +28,7 @@ RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
NO_BUILD= yes
PATCHDIR= /dev/null
-OPTIONS+= GDBM "Use gdbm instead of system bdb" off
+OPTIONS_DEFINE+= GDBM
.include "${.CURDIR}/Makefile.opt"
@@ -211,7 +211,7 @@ pre-install:
.endif # ${PKGNAMESUFFIX} == "-base"
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} ${_SHROWNGRP} -d ${DOCSDIR}
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
diff --git a/security/courier-authlib/Makefile.dep b/security/courier-authlib/Makefile.dep
index af74c2d904b0..5238c4e7491d 100644
--- a/security/courier-authlib/Makefile.dep
+++ b/security/courier-authlib/Makefile.dep
@@ -1,9 +1,5 @@
-# New ports collection makefile for: courier-authlib
-# Date created: 19 Dec 2004
-# Whom: Oliver Lehmann
-#
+# Created by: Oliver Lehmann
# $FreeBSD$
-#
# To depend on courier-authlib you might consider using this file by specifying
#
@@ -14,22 +10,22 @@
# in your Makefile *before* any
#.include <bsd.port.pre.mk>
-.if defined(WITH_AUTH_LDAP)
+.if ${PORT_OPTIONS:MAUTH_LDAP}
BUILD_DEPENDS+= ${LOCALBASE}/lib/courier-authlib/libauthldap.so:${PORTSDIR}/net/courier-authlib-ldap
.endif
-.if defined(WITH_AUTH_MYSQL)
+.if ${PORT_OPTIONS:MAUTH_MYSQL}
BUILD_DEPENDS+= ${LOCALBASE}/lib/courier-authlib/libauthmysql.so:${PORTSDIR}/databases/courier-authlib-mysql
.endif
-.if defined(WITH_AUTH_PGSQL)
+.if ${PORT_OPTIONS:MAUTH_PGSQL}
BUILD_DEPENDS+= ${LOCALBASE}/lib/courier-authlib/libauthpgsql.so:${PORTSDIR}/databases/courier-authlib-pgsql
.endif
-.if defined(WITH_AUTH_USERDB)
-.if defined(WITH_GDBM)
+.if ${PORT_OPTIONS:MAUTH_USERDB}
+.if ${PORT_OPTIONS:MGDBM}
BUILD_DEPENDS+= ${LOCALBASE}/lib/courier-authlib/libauthuserdb.so:${PORTSDIR}/databases/courier-authlib-usergdbm
.else
BUILD_DEPENDS+= ${LOCALBASE}/lib/courier-authlib/libauthuserdb.so:${PORTSDIR}/databases/courier-authlib-userdb
.endif
.endif
-.if defined(WITH_AUTH_VCHKPW)
+.if ${PORT_OPTIONS:MAUTH_VCHKPW}
BUILD_DEPENDS+= ${LOCALBASE}/lib/courier-authlib/libauthvchkpw.so:${PORTSDIR}/mail/courier-authlib-vchkpw
.endif
diff --git a/security/courier-authlib/Makefile.opt b/security/courier-authlib/Makefile.opt
index 38cc1f299c40..0b8175965af8 100644
--- a/security/courier-authlib/Makefile.opt
+++ b/security/courier-authlib/Makefile.opt
@@ -1,9 +1,5 @@
-# New ports collection makefile for: courier-authlib
-# Date created: 19 Dec 2004
-# Whom: Oliver Lehmann
-#
+# Created by: Oliver Lehmann
# $FreeBSD$
-#
# To depend on courier-authlib you might consider using this file by specifying
#
@@ -14,8 +10,9 @@
# in your Makefile *after* any
#.include <bsd.port.pre.mk>
-OPTIONS+= AUTH_LDAP "LDAP support" off \
- AUTH_MYSQL "MySQL support" off \
- AUTH_PGSQL "PostgreSQL support" off \
- AUTH_USERDB "Userdb support" off \
- AUTH_VCHKPW "Vpopmail/vchkpw support" off
+OPTIONS_DEFINE+= AUTH_LDAP AUTH_MYSQL AUTH_PGSQL AUTH_USERDB AUTH_VCHKPW
+AUTH_LDAP_DESC= LDAP support
+AUTH_MYSQL_DESC= MySQL support
+AUTH_PGSQL_DESC= PostgreSQL support
+AUTH_USERDB_DESC= Userdb support
+AUTH_VCHKPW_DESC= popmail/vchkpw support