aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2015-12-28 19:56:59 +0800
committerarved <arved@FreeBSD.org>2015-12-28 19:56:59 +0800
commit24732d0767024899a940f1ad81aed93f42a89160 (patch)
tree6d00840c074a762ea8cbbba2c4c0652315325225 /security
parentf2b488161cae9f300a3246f19335e4e1b1751b58 (diff)
downloadfreebsd-ports-gnome-24732d0767024899a940f1ad81aed93f42a89160.tar.gz
freebsd-ports-gnome-24732d0767024899a940f1ad81aed93f42a89160.tar.zst
freebsd-ports-gnome-24732d0767024899a940f1ad81aed93f42a89160.zip
* add support for JPEG
PR: 205650 Submitted by: rene * while here, add Option to disable NLS
Diffstat (limited to 'security')
-rw-r--r--security/steghide/Makefile23
-rw-r--r--security/steghide/pkg-plist20
2 files changed, 26 insertions, 17 deletions
diff --git a/security/steghide/Makefile b/security/steghide/Makefile
index 3c735fcd7b5c..a8fa03f9d97d 100644
--- a/security/steghide/Makefile
+++ b/security/steghide/Makefile
@@ -3,26 +3,35 @@
PORTNAME= steghide
PORTVERSION= 0.5.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= security
MASTER_SITES= SF
MAINTAINER= arved@FreeBSD.org
COMMENT= Steganography tool to hide data in binary files
-LIB_DEPENDS= libmcrypt.so:${PORTSDIR}/security/libmcrypt \
- libmhash.so:${PORTSDIR}/security/mhash
-
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gettext gmake libtool:build perl5
+LIB_DEPENDS= libmcrypt.so:${PORTSDIR}/security/libmcrypt \
+ libmhash.so:${PORTSDIR}/security/mhash
+
+USES= gmake jpeg libtool:build perl5
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -fpermissive
-LIBS+= -L${LOCALBASE}/lib -lintl -lmcrypt
+LIBS+= -L${LOCALBASE}/lib -lmcrypt
MAKE_ARGS= LIBTOOL="${LOCALBASE}/bin/libtool"
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+LIBS+= -lintl
+.endif
post-patch:
@${REINPLACE_CMD} '/CXXFLAGS=/s|-O2|${CXXFLAGS}|' ${WRKSRC}/configure
diff --git a/security/steghide/pkg-plist b/security/steghide/pkg-plist
index 98acecc33d5f..450a3401d926 100644
--- a/security/steghide/pkg-plist
+++ b/security/steghide/pkg-plist
@@ -1,12 +1,12 @@
bin/steghide
-%%PORTDOCS%%share/doc/steghide/BUGS
-%%PORTDOCS%%share/doc/steghide/CREDITS
-%%PORTDOCS%%share/doc/steghide/HISTORY
-%%PORTDOCS%%share/doc/steghide/LEAME
-%%PORTDOCS%%share/doc/steghide/README
-%%PORTDOCS%%share/doc/steghide/TODO
-share/locale/de/LC_MESSAGES/steghide.mo
-share/locale/es/LC_MESSAGES/steghide.mo
-share/locale/fr/LC_MESSAGES/steghide.mo
-share/locale/ro/LC_MESSAGES/steghide.mo
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/HISTORY
+%%PORTDOCS%%%%DOCSDIR%%/LEAME
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%NLS%%share/locale/de/LC_MESSAGES/steghide.mo
+%%NLS%%share/locale/es/LC_MESSAGES/steghide.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/steghide.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/steghide.mo
man/man1/steghide.1.gz