aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-04-26 00:13:38 +0800
committermat <mat@FreeBSD.org>2016-04-26 00:13:38 +0800
commit249200c5ac5a6482e3f464dcbabf7f4879065734 (patch)
tree2cf1a158cf8540bcd6bed759d4e35240e31330bb /security
parent4a29dd7050d143c963a767fa8b7671e3a0ddc09d (diff)
downloadfreebsd-ports-gnome-249200c5ac5a6482e3f464dcbabf7f4879065734.tar.gz
freebsd-ports-gnome-249200c5ac5a6482e3f464dcbabf7f4879065734.tar.zst
freebsd-ports-gnome-249200c5ac5a6482e3f464dcbabf7f4879065734.zip
Remove USE_SQLITE from bsd.databases.mk, replaced by USES=sqlite.
While there replace USE_SQLITE=x by USES=sqlite:x. PR: 208971 Submitted by: mat Exp-run by: antoine With hat: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D5951
Diffstat (limited to 'security')
-rw-r--r--security/cyrus-sasl2/Makefile4
-rw-r--r--security/heimdal/Makefile2
-rw-r--r--security/libpreludedb/Makefile2
3 files changed, 4 insertions, 4 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 3f4227ee8058..4acd85b04237 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -45,10 +45,10 @@ MYSQL_CONFIGURE_OFF= --without-mysql
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-pgsql=${LOCALBASE}
PGSQL_CONFIGURE_OFF= --without-pgsql
-SQLITE2_USE= SQLITE=2
+SQLITE2_USES= sqlite:2
SQLITE2_CONFIGURE_ON= --with-sqlite=${LOCALBASE}
SQLITE2_CONFIGURE_OFF= --without-sqlite
-SQLITE3_USE= SQLITE=3
+SQLITE3_USES= sqlite:3
SQLITE3_CONFIGURE_ON= --with-sqlite3=${LOCALBASE}
SQLITE3_CONFIGURE_OFF= --without-sqlite3
ANONYMOUS_DESC= ANONYMOUS authentication
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index b11657491ed8..b2f3cf6c400b 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -61,7 +61,7 @@ BDB_CONFIGURE_ON= --with-berkeley-db \
BDB_CONFIGURE_OFF= --without-berkeley-db
SQLITE_DESC= Enable SQLite KDC backend support
-SQLITE_USE= SQLITE=yes
+SQLITE_USES= sqlite
SQLITE_CONFIGURE_ON= --with-sqlite3 \
--with-sqlite3-include="${LOCALBASE}/include" \
--with-sqlite3-lib="${LOCALBASE}/lib"
diff --git a/security/libpreludedb/Makefile b/security/libpreludedb/Makefile
index 5be215e14ca3..c4ced1210fd0 100644
--- a/security/libpreludedb/Makefile
+++ b/security/libpreludedb/Makefile
@@ -37,7 +37,7 @@ PYTHON_USES= python:2.7
PYTHON_CONFIGURE_WITH= python2=${PYTHON_CMD}
PYTHON_PLIST_SUB= VERSION=${PORTVERSION}
SQLITE_DESC= SQLite3 plugin
-SQLITE_USE= sqlite=yes
+SQLITE_USES= sqlite
SQLITE_CONFIGURE_WITH= sqlite3
.include <bsd.port.mk>