aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-07-10 09:59:13 +0800
committersteve <steve@FreeBSD.org>2000-07-10 09:59:13 +0800
commit2677afeaaad49ea4f1266ecb2b72d8132bbd4b1b (patch)
tree5b4828f3bf921b008aab89d1ecb242a8900cce3b /security
parent4bd6d4fb3aba470ef5996ad525b86d700d85c8d0 (diff)
downloadfreebsd-ports-gnome-2677afeaaad49ea4f1266ecb2b72d8132bbd4b1b.tar.gz
freebsd-ports-gnome-2677afeaaad49ea4f1266ecb2b72d8132bbd4b1b.tar.zst
freebsd-ports-gnome-2677afeaaad49ea4f1266ecb2b72d8132bbd4b1b.zip
Use DEFAULTPGP to set the desired version of PGP/GPG.
PR: 19171 Submitted by: maintainer
Diffstat (limited to 'security')
-rw-r--r--security/p5-PGP-Sign/Makefile47
1 files changed, 29 insertions, 18 deletions
diff --git a/security/p5-PGP-Sign/Makefile b/security/p5-PGP-Sign/Makefile
index 57b3b2b07ef9..6b482469607a 100644
--- a/security/p5-PGP-Sign/Makefile
+++ b/security/p5-PGP-Sign/Makefile
@@ -19,45 +19,56 @@ USE_PERL5= yes
MAN3= PGP::Sign.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-# You can either define one of these on the command line or accept the
-# default (WITH_PGP2). You can also predefine the values for PGP (or
-# PGPS and PGPV) and PGPSTYLE if you don't like what this makefile
-# would assign.
-# WITH_PGP2 - use PGP 2.6.* or a reasonable facsimile thereof
-# WITH_PGP5 - use PGP 5 or a work-alike
-# WITH_GPG - use Gnu Privacy Guard
+# If DEFAULTPGP isn't defined, it gets set to PGP2. If you don't like
+# the values that this process assigns to PGP (or PGPV and PGPS) and
+# PGPSTYLE, they can be predefined.
+#
+# Currently useful values for DEFAULTPGP are:
+# PGP2 - PGP 2.6.* or a reasonable facsimile thereof
+# PGP5 - PGP 5 or a work-alike
+# PGP6 - PGP 6.5 (effectively the same as PGP2)
+# GPG - Gnu Privacy Guard
+
+.ifndef DEFAULTPGP
+DEFAULTPGP= PGP2
+.endif
-.if !defined(WITH_PGP5) && !defined(WITH_GPG)
-WITH_PGP2?= yes
+.if (${DEFAULTPGP} == PGP2 )
RUN_DEPENDS= pgp:${PORTSDIR}/security/pgp
+PGPSTYLE?= PGP2
.ifndef PGP
PGP!= which pgp || ${ECHO} ${PREFIX}/bin/pgp
.endif
-PGPSTYLE?= PGP2
-.else
-.ifdef WITH_PGP5
+.elif (${DEFAULTPGP} == PGP5 )
RUN_DEPENDS= pgps:${PORTSDIR}/security/pgp5
+PGPSTYLE?= PGP5
.ifndef PGPS
PGPS!= which pgps || ${ECHO} ${PREFIX}/bin/pgps
.endif
.ifndef PGPV
PGPV!= which pgpv || ${ECHO} ${PREFIX}/bin/pgpv
.endif
-PGPSTYLE?= PGP5
+.elif (${DEFAULTPGP} == PGP6)
+RUN_DEPENDS= pgp:${PORTSDIR}/security/pgp6
+PGPSTYLE?= PGP6
+.ifndef PGP
+PGP!= which pgp || ${ECHO} ${PREFIX}/bin/pgp
.endif
-.ifdef WITH_GPG
+.elif (${DEFAULTPGP} == GPG)
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+PGPSTYLE?= GPG
.ifndef PGP
PGP!= which gpg || ${ECHO} ${PREFIX}/bin/gpg
.endif
-PGPSTYLE?= GPG
-.endif
+.else
+.error Unsupported DEFAULTPGP value. See the Makefile for a list of acceptable values.
.endif
.ifdef PGP
-PGPS= ${PGP}
-PGPV= ${PGP}
+PGPS?= ${PGP}
+PGPV?= ${PGP}
.endif
+
CONFIG_ARGS= PGPS=${PGPS} PGPV=${PGPV} PGPSTYLE=${PGPSTYLE}
do-configure: