aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-07-28 00:45:26 +0800
committermarino <marino@FreeBSD.org>2013-07-28 00:45:26 +0800
commit3311d519b8d5c595f4f211a9abf7633037ee2775 (patch)
tree976f88a9f95968c75251d39fe6efcfddc8de086c /security
parent0a9e5efb9de6b8811964b263c03b83ec89719f71 (diff)
downloadfreebsd-ports-gnome-3311d519b8d5c595f4f211a9abf7633037ee2775.tar.gz
freebsd-ports-gnome-3311d519b8d5c595f4f211a9abf7633037ee2775.tar.zst
freebsd-ports-gnome-3311d519b8d5c595f4f211a9abf7633037ee2775.zip
security/courier(passd,passwd,userinfo): Unbreak fetch and cleanup
The maintainer provided a new download location for his three ports after a site reorganization broke fetching for two of them. In addition to updating the MASTER_SITES, other cleanups where performed: * Trim Headers * Convert USE_GMAKE to USES+=gmake * Convert NOPORTDOCS to options DOCS * Removed unterminated string in courierpassd makefile * Removed empty strings in courierpassd makefile PR: ports/179670 Approved by: bapt / culot (mentors, implicit)
Diffstat (limited to 'security')
-rw-r--r--security/courierpassd/Makefile28
-rw-r--r--security/courierpasswd/Makefile15
-rw-r--r--security/courieruserinfo/Makefile15
3 files changed, 30 insertions, 28 deletions
diff --git a/security/courierpassd/Makefile b/security/courierpassd/Makefile
index 2388bed64d38..ae00caea88ea 100644
--- a/security/courierpassd/Makefile
+++ b/security/courierpassd/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: courierpassd
-# Date created: 26th July 2005
-# Whom: Ade Lovett <ade@FreeBSD.org>
-#
+# Created by: Ade Lovett <ade@FreeBSD.org>
# $FreeBSD$
PORTNAME= courierpassd
PORTVERSION= 1.1.2
CATEGORIES= security mail
-#MASTER_SITES= http://www.arda.homeunix.net/store/
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= ade
+MASTER_SITES= http://www.arda.homeunix.net/software-downloads/ \
+ LOCAL/ade
MAINTAINER= andrew@arda.homeunix.net
COMMENT= User authentication and password changing daemon utility
@@ -28,25 +24,29 @@ CONFIGURE_ARGS+=--with-minuid=${MINUID} --with-badpassdelay=${DELAY}
MAN8= courierpassd.8
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
pre-everything::
- @${ECHO} ""
+ @${ECHO}
@${ECHO} "###########################################################"
- @${ECHO} ""
+ @${ECHO}
@${ECHO} "The following build options are available:"
- @${ECHO} "
+ @${ECHO}
@${ECHO} " MINUID=uid"
@${ECHO} " Accounts with uids below this value cannot have"
@${ECHO} " their passwords changed. Default value is 100."
- @${ECHO} ""
+ @${ECHO}
@${ECHO} " DELAY=sec"
@${ECHO} " Set the delay after a password change failure."
@${ECHO} " Default is 3 seconds."
- @${ECHO} ""
+ @${ECHO}
@${ECHO} "###########################################################"
- @${ECHO} ""
+ @${ECHO}
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
diff --git a/security/courierpasswd/Makefile b/security/courierpasswd/Makefile
index 5edca04e66a7..924797189ab0 100644
--- a/security/courierpasswd/Makefile
+++ b/security/courierpasswd/Makefile
@@ -1,13 +1,10 @@
-# New ports collection makefile for: courierpasswd
-# Date created: 23th April 2006
-# Whom: Andrew St. Jean <andrew@arda.homeunix.net>
-#
+# Created by: Andrew St. Jean <andrew@arda.homeunix.net>
# $FreeBSD$
PORTNAME= courierpasswd
PORTVERSION= 1.1.2
CATEGORIES= security mail
-MASTER_SITES= http://www.arda.homeunix.net/store/
+MASTER_SITES= http://www.arda.homeunix.net/software-downloads/
MAINTAINER= andrew@arda.homeunix.net
COMMENT= User authentication and password changing utility
@@ -16,7 +13,7 @@ BUILD_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -26,6 +23,10 @@ CONFIGURE_ARGS+= --with-minuid=${MINUID}
MAN8= courierpasswd.8
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
pre-fetch:
@${ECHO} ""
@${ECHO} "#############################################################"
@@ -40,7 +41,7 @@ pre-fetch:
@${ECHO} ""
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
diff --git a/security/courieruserinfo/Makefile b/security/courieruserinfo/Makefile
index 1a4216259efa..059020f37ca2 100644
--- a/security/courieruserinfo/Makefile
+++ b/security/courieruserinfo/Makefile
@@ -1,13 +1,10 @@
-# New ports collection makefile for: courieruserinfo
-# Date created: 27th July 2006
-# Whom: Andrew St. Jean <andrew@arda.homeunix.net>
-#
+# Created by: Andrew St. Jean <andrew@arda.homeunix.net>
# $FreeBSD$
PORTNAME= courieruserinfo
PORTVERSION= 1.1.2
CATEGORIES= security mail
-MASTER_SITES= http://www.arda.homeunix.net/store/
+MASTER_SITES= http://www.arda.homeunix.net/software-downloads/
MAINTAINER= andrew@arda.homeunix.net
COMMENT= User account information retrieval utility
@@ -16,14 +13,18 @@ BUILD_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAN8= courieruserinfo.8
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}