aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-05-10 17:03:31 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-05-10 17:03:31 +0800
commit3990d9291b3ba2429ef99b262f620e251a48c2cc (patch)
treedd5fad54002fcd820056289a1237478b98a93e0c /security
parentfdb653cf92dc52758fdbc7b7ba15b87efe75d99b (diff)
downloadfreebsd-ports-gnome-3990d9291b3ba2429ef99b262f620e251a48c2cc.tar.gz
freebsd-ports-gnome-3990d9291b3ba2429ef99b262f620e251a48c2cc.tar.zst
freebsd-ports-gnome-3990d9291b3ba2429ef99b262f620e251a48c2cc.zip
- Add LICENSE
- Switch to options helpers - Regenerate patches with `make makepatch`
Diffstat (limited to 'security')
-rw-r--r--security/chrootuid/Makefile9
-rw-r--r--security/chrootuid/files/patch-Makefile4
-rw-r--r--security/chrootuid/files/patch-chrootuid.14
-rw-r--r--security/chrootuid/files/patch-chrootuid.c6
4 files changed, 14 insertions, 9 deletions
diff --git a/security/chrootuid/Makefile b/security/chrootuid/Makefile
index 9b63a0fef389..90d403e1c377 100644
--- a/security/chrootuid/Makefile
+++ b/security/chrootuid/Makefile
@@ -11,15 +11,20 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple wrapper that combines chroot(8) and su(1) into one program
+LICENSE= MIT # MIT-like actually
+LICENSE_FILE= ${WRKSRC}/chrootuid_license
+
PLIST_FILES= sbin/chrootuid man/man8/chrootuid.1.gz
PORTDOCS= README
OPTIONS_DEFINE= DOCS
do-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
${INSTALL_PROGRAM} ${WRKSRC}/chrootuid ${STAGEDIR}${PREFIX}/sbin/
${INSTALL_MAN} ${WRKSRC}/chrootuid.1 ${STAGEDIR}${PREFIX}/man/man8
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/security/chrootuid/files/patch-Makefile b/security/chrootuid/files/patch-Makefile
index 0c2d31bc12e2..736ae60f9cf0 100644
--- a/security/chrootuid/files/patch-Makefile
+++ b/security/chrootuid/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Thu Aug 12 07:09:31 1993
-+++ Makefile Sun Jun 23 15:01:35 2002
+--- Makefile.orig 1993-08-12 14:09:31 UTC
++++ Makefile
@@ -1,7 +1,7 @@
# @(#) Makefile 1.2 93/08/12 16:09:29
diff --git a/security/chrootuid/files/patch-chrootuid.1 b/security/chrootuid/files/patch-chrootuid.1
index d3a48f10cbf8..cf5852100030 100644
--- a/security/chrootuid/files/patch-chrootuid.1
+++ b/security/chrootuid/files/patch-chrootuid.1
@@ -1,5 +1,5 @@
---- chrootuid.1.orig Wed Jul 25 09:46:59 2001
-+++ chrootuid.1 Sun Jun 23 15:01:19 2002
+--- chrootuid.1.orig 2001-07-25 16:46:59 UTC
++++ chrootuid.1
@@ -1,4 +1,4 @@
-.TH CHROOTUID 1
+.TH CHROOTUID 8
diff --git a/security/chrootuid/files/patch-chrootuid.c b/security/chrootuid/files/patch-chrootuid.c
index cd8409e00a2a..1abab61a42c9 100644
--- a/security/chrootuid/files/patch-chrootuid.c
+++ b/security/chrootuid/files/patch-chrootuid.c
@@ -1,6 +1,6 @@
---- chrootuid.c.orig Wed Jul 25 09:47:44 2001
-+++ chrootuid.c Sun Jun 23 15:06:10 2002
-@@ -81,6 +81,10 @@
+--- chrootuid.c.orig 2001-07-25 16:47:44 UTC
++++ chrootuid.c
+@@ -81,6 +81,10 @@ char **argv;
syslog(LOG_ERR, "usage: %s path user command", argv[0]);
return (0);
}