aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-09-04 04:21:15 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-09-04 04:21:15 +0800
commit40e905e4b57127f3f6075661e706d538f3e1d841 (patch)
tree7a328943fd6a77cebb230907b1f8296369ca5cb1 /security
parentcf997f0b446e1a38ea13e39eca71cb37ede90ef0 (diff)
downloadfreebsd-ports-gnome-40e905e4b57127f3f6075661e706d538f3e1d841.tar.gz
freebsd-ports-gnome-40e905e4b57127f3f6075661e706d538f3e1d841.tar.zst
freebsd-ports-gnome-40e905e4b57127f3f6075661e706d538f3e1d841.zip
- Add p5-Crypt-OpenSSL-CA 0.21
Crypt-OpenSSL-CA - Model of an X509v3 Certification Authority This package performs the cryptographic operations necessary to issue X509 certificates and certificate revocation lists (CRLs). It is implemented as a Perl wrapper around the popular OpenSSL library. All certificate and CRL extensions supported by OpenSSL are available, and then some. WWW: http://search.cpan.org/dist/Crypt-OpenSSL-CA/ PR: ports/160167 Submitted by: Rodrigo Mosconi <freebsd@mosconi.mat.br>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-OpenSSL-CA/Makefile41
-rw-r--r--security/p5-Crypt-OpenSSL-CA/distinfo2
-rw-r--r--security/p5-Crypt-OpenSSL-CA/pkg-descr9
-rw-r--r--security/p5-Crypt-OpenSSL-CA/pkg-plist33
5 files changed, 86 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 862df382f47b..b9fff19d6605 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -427,6 +427,7 @@
SUBDIR += p5-Crypt-OpenPGP
SUBDIR += p5-Crypt-OpenSSL-AES
SUBDIR += p5-Crypt-OpenSSL-Bignum
+ SUBDIR += p5-Crypt-OpenSSL-CA
SUBDIR += p5-Crypt-OpenSSL-DSA
SUBDIR += p5-Crypt-OpenSSL-RSA
SUBDIR += p5-Crypt-OpenSSL-Random
diff --git a/security/p5-Crypt-OpenSSL-CA/Makefile b/security/p5-Crypt-OpenSSL-CA/Makefile
new file mode 100644
index 000000000000..7e399dce3cce
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-CA/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: p5-Crypt-OpenSSL-CA
+# Date created: 2011/08/25
+# Whom: Mosconi <mosconi.rmg@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-OpenSSL-CA
+PORTVERSION= 0.21
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl extension for OpenSSL CA API
+
+BUILD_DEPENDS= p5-Convert-ASN1>=0.02:${PORTSDIR}/converters/p5-Convert-ASN1 \
+ p5-Devel-Leak>=0:${PORTSDIR}/devel/p5-Devel-Leak \
+ p5-Devel-Mallinfo>=0:${PORTSDIR}/devel/p5-Devel-Mallinfo \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run \
+ p5-Inline>=0.4:${PORTSDIR}/devel/p5-Inline \
+ p5-Net-SSLeay>=1.25:${PORTSDIR}/security/p5-Net-SSLeay
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-Test-Group>=0:${PORTSDIR}/devel/p5-Test-Group
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::OpenSSL::CA.3 \
+ Crypt::OpenSSL::CA::AlphabetSoup.3 \
+ Crypt::OpenSSL::CA::Inline::C.3 \
+ Crypt::OpenSSL::CA::Resources.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-Module-Build>=0.2900:${PORTSDIR}/devel/p5-Module-Build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-OpenSSL-CA/distinfo b/security/p5-Crypt-OpenSSL-CA/distinfo
new file mode 100644
index 000000000000..a3fe06ade0ae
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-CA/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-OpenSSL-CA-0.21.tar.gz) = 0c669519acff1252187e8d7814ed39f2aa3767b84e9e86bf26720956748d53fe
+SIZE (Crypt-OpenSSL-CA-0.21.tar.gz) = 140788
diff --git a/security/p5-Crypt-OpenSSL-CA/pkg-descr b/security/p5-Crypt-OpenSSL-CA/pkg-descr
new file mode 100644
index 000000000000..e619adc992d0
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-CA/pkg-descr
@@ -0,0 +1,9 @@
+Crypt-OpenSSL-CA - Model of an X509v3 Certification Authority
+
+This package performs the cryptographic operations necessary to issue
+X509 certificates and certificate revocation lists (CRLs). It is
+implemented as a Perl wrapper around the popular OpenSSL library. All
+certificate and CRL extensions supported by OpenSSL are available, and
+then some.
+
+WWW: http://search.cpan.org/dist/Crypt-OpenSSL-CA/
diff --git a/security/p5-Crypt-OpenSSL-CA/pkg-plist b/security/p5-Crypt-OpenSSL-CA/pkg-plist
new file mode 100644
index 000000000000..66c8c4b4bfb3
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-CA/pkg-plist
@@ -0,0 +1,33 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/OpenSSL/CA.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/OpenSSL/CA/AlphabetSoup.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/OpenSSL/CA/Inline/C.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/OpenSSL/CA/Resources.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/CONF/CONF.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/CONF/CONF.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/PrivateKey/PrivateKey.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/PrivateKey/PrivateKey.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/PublicKey/PublicKey.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/PublicKey/PublicKey.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/X509/X509.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/X509/X509.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/X509V3_EXT/X509V3_EXT.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/X509V3_EXT/X509V3_EXT.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/X509_CRL/X509_CRL.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/X509_CRL/X509_CRL.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/X509_NAME/X509_NAME.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/X509_NAME/X509_NAME.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/X509_NAME
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/X509_CRL
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/X509V3_EXT
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/X509
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/PublicKey
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/PrivateKey
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA/CONF
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/CA
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Crypt/OpenSSL/CA/Inline
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Crypt/OpenSSL/CA
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Crypt/OpenSSL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Crypt