aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2015-03-18 05:01:56 +0800
committerpi <pi@FreeBSD.org>2015-03-18 05:01:56 +0800
commit4a3af74ca8d9f0f242f270ac277219c49b2c7941 (patch)
tree64ae0db351321f78edbca9e90e71ddfd07c5bd7a /security
parentdd6af2f5582a2930866fe07aae229cac7cf923c1 (diff)
downloadfreebsd-ports-gnome-4a3af74ca8d9f0f242f270ac277219c49b2c7941.tar.gz
freebsd-ports-gnome-4a3af74ca8d9f0f242f270ac277219c49b2c7941.tar.zst
freebsd-ports-gnome-4a3af74ca8d9f0f242f270ac277219c49b2c7941.zip
security/polarssl: 1.2.12 -> 1.2.13
Changes: https://tls.mbed.org/tech-updates/releases/polarssl-1.2.13-released PR: 197780 Submitted by: takefu@airport.fm Approved by: jase (maintainer timeout)
Diffstat (limited to 'security')
-rw-r--r--security/polarssl/Makefile7
-rw-r--r--security/polarssl/distinfo4
-rw-r--r--security/polarssl/files/patch-library-asn1parse_c11
3 files changed, 5 insertions, 17 deletions
diff --git a/security/polarssl/Makefile b/security/polarssl/Makefile
index cfb460f6985b..aa363334c4b3 100644
--- a/security/polarssl/Makefile
+++ b/security/polarssl/Makefile
@@ -1,11 +1,10 @@
# $FreeBSD$
PORTNAME= polarssl
-PORTVERSION= 1.2.12
-PORTREVISION= 1
+PORTVERSION= 1.2.13
DISTVERSIONSUFFIX= -gpl
CATEGORIES= security devel
-MASTER_SITES= http://polarssl.org/download/
+MASTER_SITES= https://polarssl.org/download/
MAINTAINER= jase@FreeBSD.org
COMMENT= Open Source embedded SSL/TLS cryptographic library
@@ -14,7 +13,7 @@ LICENSE= GPLv2
ALL_TARGET= no_test
-USES= cpe gmake tar:tgz
+USES= cpe gmake tar:tgz
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/security/polarssl/distinfo b/security/polarssl/distinfo
index 529d088010c8..3f1855f56ad8 100644
--- a/security/polarssl/distinfo
+++ b/security/polarssl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (polarssl-1.2.12-gpl.tgz) = 63dd60e78d25c438648607bb177b063dcf5fbf3ced9ee794fcb165d101940131
-SIZE (polarssl-1.2.12-gpl.tgz) = 1021400
+SHA256 (polarssl-1.2.13-gpl.tgz) = 62f44f2a9f39b5cefb229e5dd2644ca20ead477cb1843d6ff30671624315b021
+SIZE (polarssl-1.2.13-gpl.tgz) = 1023128
diff --git a/security/polarssl/files/patch-library-asn1parse_c b/security/polarssl/files/patch-library-asn1parse_c
deleted file mode 100644
index 07f3c46af7f3..000000000000
--- a/security/polarssl/files/patch-library-asn1parse_c
+++ /dev/null
@@ -1,11 +0,0 @@
---- library/asn1parse.c.orig 2015-01-19 19:31:49.664592954 +0000
-+++ library/asn1parse.c 2015-01-19 19:34:11.583587052 +0000
-@@ -244,6 +244,8 @@
- if( cur->next == NULL )
- return( POLARSSL_ERR_ASN1_MALLOC_FAILED );
-
-+ memset( cur->next, 0, sizeof( asn1_sequence ) );
-+
- cur = cur->next;
- }
- }