aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2004-11-10 00:39:05 +0800
committersergei <sergei@FreeBSD.org>2004-11-10 00:39:05 +0800
commit669bff70d78b13830caa790932873ef3f72ebbb0 (patch)
tree1fcaf3b247f2401165856900edc7510ff912c28b /security
parent339648b49f88805f9e701a38f8c70abaab9bde27 (diff)
downloadfreebsd-ports-gnome-669bff70d78b13830caa790932873ef3f72ebbb0.tar.gz
freebsd-ports-gnome-669bff70d78b13830caa790932873ef3f72ebbb0.tar.zst
freebsd-ports-gnome-669bff70d78b13830caa790932873ef3f72ebbb0.zip
Add security/sks - SKS OpenPGP Key Server:
SKS is a new OpenPGP keyserver whose goal is to provide easy to deploy, decentralized, and highly reliable synchronization. That means that a key submitted to one SKS server will quickly be distributed to all key servers; and even wildly out-of-date servers, or servers that experience spotty connectivity, can fully synchronize with rest of the system. Refer to the online wiki for pointers on downloading a full copy of the public PGP databse (about 4Gb) and on customising the local configuration http://documentation.penguin.de/cgi-bin/twiki/view/SKSKeyserver/WebHome WWW: http://www.nongnu.org/sks/ PR: ports/72842 Submitted by: Johan van Selst <johans@stack.nl>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/sks/Makefile48
-rw-r--r--security/sks/distinfo4
-rw-r--r--security/sks/files/patch-Makefile19
-rw-r--r--security/sks/files/patch-mRandom.ml11
-rw-r--r--security/sks/files/patch-sks_build.sh8
-rw-r--r--security/sks/files/sks.numerix.patch30
-rw-r--r--security/sks/pkg-descr13
8 files changed, 134 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e7d18395d1ee..205f5002e2d8 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -409,6 +409,7 @@
SUBDIR += shishi
SUBDIR += sig2dot
SUBDIR += skip
+ SUBDIR += sks
SUBDIR += slurpie
SUBDIR += slush
SUBDIR += smtpmap
diff --git a/security/sks/Makefile b/security/sks/Makefile
new file mode 100644
index 000000000000..29333a4bf6f7
--- /dev/null
+++ b/security/sks/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: sks
+# Date created: 2004-10-16
+# Whom: johans@stack.nl
+#
+# $FreeBSD$
+#
+
+PORTNAME= sks
+PORTVERSION= 1.0.9
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR=sks
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= johans@stack.nl
+COMMENT= Synchronizing Key Server, a fast OpenPGP keyserver
+
+BUILD_DEPENDS= ocaml:${PORTSDIR}/lang/ocaml
+LIB_DEPENDS= db41:${PORTSDIR}/databases/db41
+
+USE_GPG= yes
+SIG_SUFFIX= .sig
+USE_GMAKE= yes
+MAKE_ENV= BDBINCLUDE="-I${LOCALBASE}/include/db41" \
+ BDBLIB="-L${LOCALBASE}/lib" \
+ LIBDB="-ldb41" \
+ MANDIR="${MANPREFIX}/man"
+ALL_TARGET= all sks.8
+USE_PERL5_BUILD= yes
+
+PLIST_FILES= bin/sks bin/sks_add_mail bin/sks_build.sh
+MAN8= sks.8
+PORTDOCS= ANNOUNCEMENT BUGS README TODO
+
+post-patch:
+ @${CP} ${FILESDIR}/sks.numerix.patch ${WRKDIR}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sks ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/sks_add_mail ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/sks_build.sh ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/sks.8 ${MAN8PREFIX}/man/man8
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/sks/distinfo b/security/sks/distinfo
new file mode 100644
index 000000000000..43b005b0a049
--- /dev/null
+++ b/security/sks/distinfo
@@ -0,0 +1,4 @@
+MD5 (sks-1.0.9.tgz) = 90d42c61de9121aa5102739b2ca6c952
+SIZE (sks-1.0.9.tgz) = 925362
+MD5 (sks-1.0.9.tgz.sig) = 2eea560a34429fe5b0cb9149365eb98b
+SIZE (sks-1.0.9.tgz.sig) = 65
diff --git a/security/sks/files/patch-Makefile b/security/sks/files/patch-Makefile
new file mode 100644
index 000000000000..a69a106d2a43
--- /dev/null
+++ b/security/sks/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig Thu Oct 21 06:56:02 2004
++++ Makefile Tue Nov 9 16:35:02 2004
+@@ -148,7 +148,7 @@ sks.8.gz: sks.8
+ gzip -f sks.8
+
+ sks.8: sks.pod
+- pod2man -c "SKS OpenPGP Key server" --section 8 -r 0.1 -name sks sks.pod sks.8
++ pod2man -c "SKS OpenPGP Key server" --section 8 -r 0.1 sks.pod > sks.8
+
+ sks: $(LIBS) $(ALLOBJS) sks.cmx
+ $(OCAMLOPT) -o sks $(OCAMLOPTFLAGS) $(ALLOBJS) sks.cmx
+@@ -294,6 +294,7 @@ NXDIR=numerix-0.19
+
+ $(NXDIR)/READ.ME:
+ tar xvmfz $(NXDIR)-3.tar.gz
++ patch -p0 < ../sks.numerix.patch
+
+ $(NXDIR)/config.status: $(NXDIR)/READ.ME
+ cd $(NXDIR) && \
diff --git a/security/sks/files/patch-mRandom.ml b/security/sks/files/patch-mRandom.ml
new file mode 100644
index 000000000000..c240c6d674e5
--- /dev/null
+++ b/security/sks/files/patch-mRandom.ml
@@ -0,0 +1,11 @@
+--- mRandom.ml.orig Thu Oct 21 06:56:03 2004
++++ mRandom.ml Tue Nov 9 16:34:27 2004
+@@ -92,7 +92,7 @@ struct
+
+ (* Low-entropy system-dependent initialisation. *)
+
+- external random_seed: unit -> int = "sys_random_seed"
++ external random_seed: unit -> int = "caml_sys_random_seed"
+
+ let self_init () = init (random_seed())
+
diff --git a/security/sks/files/patch-sks_build.sh b/security/sks/files/patch-sks_build.sh
new file mode 100644
index 000000000000..0e409739772f
--- /dev/null
+++ b/security/sks/files/patch-sks_build.sh
@@ -0,0 +1,8 @@
+--- sks_build.sh.orig Thu Oct 21 06:56:04 2004
++++ sks_build.sh Tue Nov 9 16:34:27 2004
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # SKS build script.
+ # cd to directory with "dump" subdirectory, and run
diff --git a/security/sks/files/sks.numerix.patch b/security/sks/files/sks.numerix.patch
new file mode 100644
index 000000000000..a511404274ae
--- /dev/null
+++ b/security/sks/files/sks.numerix.patch
@@ -0,0 +1,30 @@
+--- numerix-0.19/configure Sat Oct 16 15:47:19 2004
++++ numerix-0.19/configure Sat Oct 16 15:38:02 2004
+@@ -4337,6 +4337,7 @@
+ echo "$as_me:$LINENO: checking for Ocaml version" >&5
+ echo $ECHO_N "checking for Ocaml version... $ECHO_C" >&6
+ ocaml_version=`config/camlconf $ocamlc version`
++ ocaml_version=${ocaml_version%%.*}
+ echo "$as_me:$LINENO: result: $ocaml_version" >&5
+ echo "${ECHO_T}$ocaml_version" >&6
+ echo "$as_me:$LINENO: checking for Ocaml directory" >&5
+--- numerix-0.19/lib/kernel/string.c Sat Oct 16 15:47:19 2004
++++ numerix-0.19/lib/kernel/string.c Sat Oct 16 15:14:17 2004
+@@ -38,7 +38,7 @@
+ longueur l;
+
+ /* saute les blancs et le signe */
+- while isspace(*s) s++;
++ while (isspace(*s)) s++;
+ if ((*s == '+') || (*s == '-')) s++;
+
+ /* compte le nombre de chiffres décimaux */
+@@ -83,7 +83,7 @@
+ long i,j,l,n;
+
+ /* saute les blancs et le signe */
+- while isspace(*s) s++;
++ while (isspace(*s)) s++;
+ switch(*s) {
+ case '-' : sa = SIGN_m;
+ case '+' : s++;
diff --git a/security/sks/pkg-descr b/security/sks/pkg-descr
new file mode 100644
index 000000000000..639f99cc66ca
--- /dev/null
+++ b/security/sks/pkg-descr
@@ -0,0 +1,13 @@
+SKS OpenPGP Key Server
+
+SKS is a new OpenPGP keyserver whose goal is to provide easy to deploy,
+decentralized, and highly reliable synchronization. That means that a
+key submitted to one SKS server will quickly be distributed to all key
+servers; and even wildly out-of-date servers, or servers that experience
+spotty connectivity, can fully synchronize with rest of the system.
+
+Refer to the online wiki for pointers on downloading a full copy of the
+public PGP databse (about 4Gb) and on customising the local configuration
+http://documentation.penguin.de/cgi-bin/twiki/view/SKSKeyserver/WebHome
+
+WWW: http://www.nongnu.org/sks/