aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-11 09:50:25 +0800
committermarino <marino@FreeBSD.org>2016-09-11 09:50:25 +0800
commit6729a6d095f36981828e40b4c6b1d0fb83648996 (patch)
treea62ef1e397e96181fcf05375426b3de8b843fa51 /security
parenta10f3d0436edfe45cd3621872b10f83949085446 (diff)
downloadfreebsd-ports-gnome-6729a6d095f36981828e40b4c6b1d0fb83648996.tar.gz
freebsd-ports-gnome-6729a6d095f36981828e40b4c6b1d0fb83648996.tar.zst
freebsd-ports-gnome-6729a6d095f36981828e40b4c6b1d0fb83648996.zip
security/erlang-p1tls: Add SSL flags
Approved by: SSL blanket
Diffstat (limited to 'security')
-rw-r--r--security/erlang-p1tls/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/security/erlang-p1tls/Makefile b/security/erlang-p1tls/Makefile
index ce6bd70eeaee..f1e4806f930b 100644
--- a/security/erlang-p1tls/Makefile
+++ b/security/erlang-p1tls/Makefile
@@ -11,8 +11,7 @@ COMMENT= TLS / SSL native driver for Erlang
LICENSE= GPLv2
-USE_OPENSSL= yes
-USES= erlang:rebar
+USES= erlang:rebar ssl
USE_GITHUB= yes
GH_ACCOUNT= processone
GH_PROJECT= tls
@@ -21,6 +20,10 @@ GH_TAGNAME= e56321a
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+CPPFLAGS+= -I${OPENSSLINC}
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/priv/lib/*.so