aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-12-20 20:35:18 +0800
committeredwin <edwin@FreeBSD.org>2005-12-20 20:35:18 +0800
commit6b8b0472ca8cf4950d6930b4b619fb62f512f30c (patch)
tree4c11f3e6ee896b53a081af1e25a4538e6437cf50 /security
parent8b7bfee772472d2c271540b959f5a75f918c2063 (diff)
downloadfreebsd-ports-gnome-6b8b0472ca8cf4950d6930b4b619fb62f512f30c.tar.gz
freebsd-ports-gnome-6b8b0472ca8cf4950d6930b4b619fb62f512f30c.tar.zst
freebsd-ports-gnome-6b8b0472ca8cf4950d6930b4b619fb62f512f30c.zip
[maintainer update]: security/samba-vscan fix atoll problem on 4.X
- Fix atoll problem with FreeBSD 4.X. PR: ports/90645 Submitted by: Jean Milanez Melo <jmelo@freebsdbrasil.com.br>
Diffstat (limited to 'security')
-rw-r--r--security/samba-vscan/Makefile8
-rw-r--r--security/samba-vscan/files/extra_patch-vscan-parameter.c10
2 files changed, 17 insertions, 1 deletions
diff --git a/security/samba-vscan/Makefile b/security/samba-vscan/Makefile
index 5d079798326a..783b6ce26da5 100644
--- a/security/samba-vscan/Makefile
+++ b/security/samba-vscan/Makefile
@@ -28,6 +28,12 @@ ETCDIR= ${PREFIX}/etc/samba-vscan
PKGMESSAGE= ${WRKDIR}/pkg-message
VSCAN_SAMBA_PORT?=samba3
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES=${FILESDIR}/extra_patch-*
+.endif
+
.if ${VSCAN_SAMBA_PORT} == "samba3"
PLIST_SUB= VFSDIR=lib/samba/vfs
.else
@@ -58,4 +64,4 @@ post-install:
@${SED} "s|%%PREFIX%%|${PREFIX}|g;" ${.CURDIR}/pkg-message > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/samba-vscan/files/extra_patch-vscan-parameter.c b/security/samba-vscan/files/extra_patch-vscan-parameter.c
new file mode 100644
index 000000000000..b146413cb733
--- /dev/null
+++ b/security/samba-vscan/files/extra_patch-vscan-parameter.c
@@ -0,0 +1,10 @@
+--- global/vscan-parameter.c.orig Mon Dec 12 01:36:54 2005
++++ global/vscan-parameter.c Mon Dec 12 01:36:54 2005
+@@ -162,6 +162,7 @@
+ */
+ /* FIXME: changed atoi to atoll, but atoll might not be available
+ on all platforms! */
++ #define atoll(a) strtoll((a), (char **)NULL, 10)
+ vscan_config->common.max_size = atoll(value);
+ DEBUG(3, ("max file size is: %lld\n", (long long)vscan_config->common.max_size));
+ \ No newline at end of file