aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-11-25 17:00:19 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-11-25 17:00:19 +0800
commit701f24e93323f7c52e02b663ba2305431b4f4dc5 (patch)
tree4f3f2e60e6986979b7f63d98f8f1ac2216e32a6d /security
parent079878157878abb88f648d480a863777ea27471f (diff)
downloadfreebsd-ports-gnome-701f24e93323f7c52e02b663ba2305431b4f4dc5.tar.gz
freebsd-ports-gnome-701f24e93323f7c52e02b663ba2305431b4f4dc5.tar.zst
freebsd-ports-gnome-701f24e93323f7c52e02b663ba2305431b4f4dc5.zip
- Add LICENSE
- Simplify build and installation - Use proper command for static lib installation
Diffstat (limited to 'security')
-rw-r--r--security/pft/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/security/pft/Makefile b/security/pft/Makefile
index ef4fd46df1ad..fa5dbab6f3f2 100644
--- a/security/pft/Makefile
+++ b/security/pft/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pft
PORTVERSION= 1.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.phenoelit.org/hp/
DISTNAME= libPJL-${PORTVERSION}-src
@@ -11,10 +11,11 @@ DISTNAME= libPJL-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Printer Job Language library and tool
+LICENSE= NONE
+
NO_WRKSUBDIR= yes
USES= gmake tar:tgz
-ALL_TARGET= libPJL.a
PLIST_FILES= bin/pft lib/libPJL.a
@@ -25,13 +26,12 @@ post-patch:
/^CPPFLAGS=/s| -g | |' ${WRKSRC}/${i}
.endfor
-post-build:
- @(cd ${WRKSRC}/pft; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} pft)
+do-build:
+ @(cd ${WRKSRC} && ${DO_MAKE_BUILD} libPJL.a)
+ @(cd ${WRKSRC}/pft && ${DO_MAKE_BUILD} pft)
do-install:
- (cd ${WRKSRC}/pft && ${INSTALL_PROGRAM} pft \
- ${STAGEDIR}${PREFIX}/bin)
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} libPJL.a \
- ${STAGEDIR}${PREFIX}/lib)
+ ${INSTALL_PROGRAM} ${WRKSRC}/pft/pft ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libPJL.a ${STAGEDIR}${PREFIX}/lib
.include <bsd.port.mk>