aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-01-06 04:02:03 +0800
committeryuri <yuri@FreeBSD.org>2018-01-06 04:02:03 +0800
commit76d8bf048cde3ed4b57b193be33eefb5482b3fce (patch)
treec7c8b5d263f8fd187e65af3dad981ad626141a6a /security
parentf9bc438886191a89a5e241e54a0e4fb48473809e (diff)
downloadfreebsd-ports-gnome-76d8bf048cde3ed4b57b193be33eefb5482b3fce.tar.gz
freebsd-ports-gnome-76d8bf048cde3ed4b57b193be33eefb5482b3fce.tar.zst
freebsd-ports-gnome-76d8bf048cde3ed4b57b193be33eefb5482b3fce.zip
Corrected shared library names that got the .abi3 suffix for python-36 and up after devel/py-cffi upgrade to 1.11.2
This is the followup for the r457997 commit that updated devel/py-cffi to 1.11.2. As it turned out, the shared object names built by py-cffi has changed in python 36. Dependent ports can choose between installing such shared object as part of their plist, or generating them in the runtime and placing them into ~/.cache/{port-name}/ The former ones, that include the shared objects in their plist, got affected. 4 of the ports were failing explicitly in their py36 flavor during the strip phase. The other 6 were either missing strip entirely, or performed the strip operation without using explicit shared object names. These 6 ports didn't trigger any build errors, and were failing silently during the runtime, making the problem very hard to detect. Precisely, .abi3 suffix is now added for the py36 flavor of relevant ports. Here are the 10 ports that got affected and are now corrected: databases/py-psycopg2cffi devel/py-pygit2 devel/py-xattr devel/py-pyopencl devel/py-atomiclong multimedia/py-librtmp net/py-nnpy security/py-bcrypt security/py-cryptography security/py-pynacl All of them got the * in the stripped shared object name, and a PORTREVISION bump.
Diffstat (limited to 'security')
-rw-r--r--security/py-bcrypt/Makefile3
-rw-r--r--security/py-cryptography/Makefile1
-rw-r--r--security/py-pynacl/Makefile3
3 files changed, 5 insertions, 2 deletions
diff --git a/security/py-bcrypt/Makefile b/security/py-bcrypt/Makefile
index a81ca37f3231..8c7dce26f9a0 100644
--- a/security/py-bcrypt/Makefile
+++ b/security/py-bcrypt/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bcrypt
PORTVERSION= 3.1.4
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -23,6 +24,6 @@ do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/bcrypt/_bcrypt.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/bcrypt/_bcrypt*.so
.include <bsd.port.mk>
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index c1347cb2334d..1c73b022d6d0 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cryptography
PORTVERSION= 2.0.3
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-pynacl/Makefile b/security/py-pynacl/Makefile
index 00038f951817..a1efd67bc3f2 100644
--- a/security/py-pynacl/Makefile
+++ b/security/py-pynacl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pynacl
DISTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -29,7 +30,7 @@ BUNDLED_NACL_LIB_DEPENDS_OFF= libsodium.so:security/libsodium
BUNDLED_NACL_MAKE_ENV_OFF= SODIUM_INSTALL=system
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/nacl/_sodium.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/nacl/_sodium*.so
do-test:
@cd ${WRKSRC} && ${SETENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} ${PYTHON_CMD} -m pytest -rs tests