aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2002-03-19 06:52:43 +0800
committercy <cy@FreeBSD.org>2002-03-19 06:52:43 +0800
commit78523cc74d08ad5ab9250e1af0e486ed5cd9659a (patch)
tree333328014e6bb0c098d211c8c84e2ab9f6d83645 /security
parentb8ebfddbd11aa9139d01f3a4ac4c5135b2d8e6cc (diff)
downloadfreebsd-ports-gnome-78523cc74d08ad5ab9250e1af0e486ed5cd9659a.tar.gz
freebsd-ports-gnome-78523cc74d08ad5ab9250e1af0e486ed5cd9659a.tar.zst
freebsd-ports-gnome-78523cc74d08ad5ab9250e1af0e486ed5cd9659a.zip
MIT currently distributes their KRB5 distribution in a tarball (.tar)
that contains the distribution itself, in a tar.gz file, and a signature certificate, contained in a detached .tar.gz.asc file. Prior to this patch, users installing MIT KRB5 had to extract the tarball into /usr/ports/distfiles, then proceed with the installation. This caused confusion among those installing the port. This patch addresses the problem by extracting the .tar.gz file from the tarball, then unpacking the .tar.gz file before continuing with the build.
Diffstat (limited to 'security')
-rw-r--r--security/krb5-16/Makefile7
-rw-r--r--security/krb5-16/distinfo2
-rw-r--r--security/krb5-17/Makefile7
-rw-r--r--security/krb5-17/distinfo2
-rw-r--r--security/krb5-appl/Makefile7
-rw-r--r--security/krb5-appl/distinfo2
-rw-r--r--security/krb5/Makefile7
-rw-r--r--security/krb5/distinfo2
8 files changed, 32 insertions, 4 deletions
diff --git a/security/krb5-16/Makefile b/security/krb5-16/Makefile
index 6586eca93f34..342b364e2d14 100644
--- a/security/krb5-16/Makefile
+++ b/security/krb5-16/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= cy@FreeBSD.org
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
KERBEROSV_URL= http://web.mit.edu/network/kerberos-form.html
+EXTRACT_SUFX= .tar
USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
@@ -76,6 +77,12 @@ do-fetch:
fi
.endif
+post-extract:
+ @${TAR} -C ${WRKDIR} -xzf ${WRKDIR}/${DISTNAME}.tar.gz
+ @${RM} ${WRKDIR}/${DISTNAME}.tar.gz ${WRKDIR}/${DISTNAME}.tar.gz.asc
+ @${CHMOD} -R ug-s,go-w ${WRKDIR}/${DISTNAME}
+ @${CHOWN} -R 0:0 ${WRKDIR}/${DISTNAME}
+
pre-build:
.if !defined(KRB5_KRB4_COMPAT)
@${ECHO} "------------------------------------------------------"
diff --git a/security/krb5-16/distinfo b/security/krb5-16/distinfo
index 144443aaf799..a1dae0e47015 100644
--- a/security/krb5-16/distinfo
+++ b/security/krb5-16/distinfo
@@ -1 +1 @@
-MD5 (krb5-1.2.4.tar.gz) = 663add9b5942be74a86fa860a3fa4167
+MD5 (krb5-1.2.4.tar) = 2ac3d6245c7690f0f377c8710091d651
diff --git a/security/krb5-17/Makefile b/security/krb5-17/Makefile
index 6586eca93f34..342b364e2d14 100644
--- a/security/krb5-17/Makefile
+++ b/security/krb5-17/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= cy@FreeBSD.org
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
KERBEROSV_URL= http://web.mit.edu/network/kerberos-form.html
+EXTRACT_SUFX= .tar
USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
@@ -76,6 +77,12 @@ do-fetch:
fi
.endif
+post-extract:
+ @${TAR} -C ${WRKDIR} -xzf ${WRKDIR}/${DISTNAME}.tar.gz
+ @${RM} ${WRKDIR}/${DISTNAME}.tar.gz ${WRKDIR}/${DISTNAME}.tar.gz.asc
+ @${CHMOD} -R ug-s,go-w ${WRKDIR}/${DISTNAME}
+ @${CHOWN} -R 0:0 ${WRKDIR}/${DISTNAME}
+
pre-build:
.if !defined(KRB5_KRB4_COMPAT)
@${ECHO} "------------------------------------------------------"
diff --git a/security/krb5-17/distinfo b/security/krb5-17/distinfo
index 144443aaf799..a1dae0e47015 100644
--- a/security/krb5-17/distinfo
+++ b/security/krb5-17/distinfo
@@ -1 +1 @@
-MD5 (krb5-1.2.4.tar.gz) = 663add9b5942be74a86fa860a3fa4167
+MD5 (krb5-1.2.4.tar) = 2ac3d6245c7690f0f377c8710091d651
diff --git a/security/krb5-appl/Makefile b/security/krb5-appl/Makefile
index 6586eca93f34..342b364e2d14 100644
--- a/security/krb5-appl/Makefile
+++ b/security/krb5-appl/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= cy@FreeBSD.org
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
KERBEROSV_URL= http://web.mit.edu/network/kerberos-form.html
+EXTRACT_SUFX= .tar
USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
@@ -76,6 +77,12 @@ do-fetch:
fi
.endif
+post-extract:
+ @${TAR} -C ${WRKDIR} -xzf ${WRKDIR}/${DISTNAME}.tar.gz
+ @${RM} ${WRKDIR}/${DISTNAME}.tar.gz ${WRKDIR}/${DISTNAME}.tar.gz.asc
+ @${CHMOD} -R ug-s,go-w ${WRKDIR}/${DISTNAME}
+ @${CHOWN} -R 0:0 ${WRKDIR}/${DISTNAME}
+
pre-build:
.if !defined(KRB5_KRB4_COMPAT)
@${ECHO} "------------------------------------------------------"
diff --git a/security/krb5-appl/distinfo b/security/krb5-appl/distinfo
index 144443aaf799..a1dae0e47015 100644
--- a/security/krb5-appl/distinfo
+++ b/security/krb5-appl/distinfo
@@ -1 +1 @@
-MD5 (krb5-1.2.4.tar.gz) = 663add9b5942be74a86fa860a3fa4167
+MD5 (krb5-1.2.4.tar) = 2ac3d6245c7690f0f377c8710091d651
diff --git a/security/krb5/Makefile b/security/krb5/Makefile
index 6586eca93f34..342b364e2d14 100644
--- a/security/krb5/Makefile
+++ b/security/krb5/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= cy@FreeBSD.org
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
KERBEROSV_URL= http://web.mit.edu/network/kerberos-form.html
+EXTRACT_SUFX= .tar
USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
@@ -76,6 +77,12 @@ do-fetch:
fi
.endif
+post-extract:
+ @${TAR} -C ${WRKDIR} -xzf ${WRKDIR}/${DISTNAME}.tar.gz
+ @${RM} ${WRKDIR}/${DISTNAME}.tar.gz ${WRKDIR}/${DISTNAME}.tar.gz.asc
+ @${CHMOD} -R ug-s,go-w ${WRKDIR}/${DISTNAME}
+ @${CHOWN} -R 0:0 ${WRKDIR}/${DISTNAME}
+
pre-build:
.if !defined(KRB5_KRB4_COMPAT)
@${ECHO} "------------------------------------------------------"
diff --git a/security/krb5/distinfo b/security/krb5/distinfo
index 144443aaf799..a1dae0e47015 100644
--- a/security/krb5/distinfo
+++ b/security/krb5/distinfo
@@ -1 +1 @@
-MD5 (krb5-1.2.4.tar.gz) = 663add9b5942be74a86fa860a3fa4167
+MD5 (krb5-1.2.4.tar) = 2ac3d6245c7690f0f377c8710091d651