aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjadawin <jadawin@FreeBSD.org>2011-05-24 16:35:26 +0800
committerjadawin <jadawin@FreeBSD.org>2011-05-24 16:35:26 +0800
commit78c80a001335048efb158739400bbcc699eea0dc (patch)
treed9be10ef65ba72fcaffa685799518dcf50d5051f /security
parente9a3cda832677296de8d09c38f1ee5bdf5737bf8 (diff)
downloadfreebsd-ports-gnome-78c80a001335048efb158739400bbcc699eea0dc.tar.gz
freebsd-ports-gnome-78c80a001335048efb158739400bbcc699eea0dc.tar.zst
freebsd-ports-gnome-78c80a001335048efb158739400bbcc699eea0dc.zip
Dicewaregen is simple perl script that generated Diceware dictionaries, that
can be used to create secure passwords. Dicewaregen relies on aspell, to make wordlist. Once you have wordlist you can create Diceware dictionary. You can make few dictionaries using different languages, merge them and then make Diceware dictionary. More info about Diceware: http://world.std.com/~reinhold/diceware.html WWW: http://hg.bsdroot.lv/aldis/dicewaregen/ PR: ports/157251 Submitted by: Aldis Berjoza <aldis at bsdroot.lv>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-dicewaregen/Makefile30
-rw-r--r--security/p5-dicewaregen/distinfo2
-rw-r--r--security/p5-dicewaregen/pkg-descr10
4 files changed, 43 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 6f24d3265cad..3c5c053f8709 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -548,6 +548,7 @@
SUBDIR += p5-Tie-EncryptedHash
SUBDIR += p5-Tree-Authz
SUBDIR += p5-Yahoo-BBAuth
+ SUBDIR += p5-dicewaregen
SUBDIR += p5-openxpki
SUBDIR += p5-openxpki-client
SUBDIR += p5-openxpki-client-html-mason
diff --git a/security/p5-dicewaregen/Makefile b/security/p5-dicewaregen/Makefile
new file mode 100644
index 000000000000..4602c8f30ece
--- /dev/null
+++ b/security/p5-dicewaregen/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-dicewaregen
+# Date created: 2011.05.22
+# Whom: Aldis Berjoza <aldis@bsdroot.lv>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dicewaregen
+PORTVERSION= 1.2
+CATEGORIES= security
+MASTER_SITES= http://files.bsdroot.lv/my/FreeBSD/distfiles/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aldis@bsdroot.lv
+COMMENT= A simple perl script to generate Diceware dictionaries for passwords
+
+LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
+
+USE_PERL5_RUN= 5.8.8+
+
+PLIST_FILES= bin/${PORTNAME}
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/dicewaregen-${REV}
+REV= a1b6ae57d64b
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/dicewaregen.pl ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/security/p5-dicewaregen/distinfo b/security/p5-dicewaregen/distinfo
new file mode 100644
index 000000000000..3e0f6eb4eb99
--- /dev/null
+++ b/security/p5-dicewaregen/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dicewaregen-1.2.tar.gz) = 3e5f3cb48c3038c7d9f965c5f816898b6dda799da83d7b98df1a2894c7e09f55
+SIZE (dicewaregen-1.2.tar.gz) = 2384
diff --git a/security/p5-dicewaregen/pkg-descr b/security/p5-dicewaregen/pkg-descr
new file mode 100644
index 000000000000..5cb997e56e05
--- /dev/null
+++ b/security/p5-dicewaregen/pkg-descr
@@ -0,0 +1,10 @@
+Dicewaregen is simple perl script that generated Diceware dictionaries, that
+can be used to create secure passwords.
+
+Dicewaregen relies on aspell, to make wordlist. Once you have wordlist you can
+create Diceware dictionary. You can make few dictionaries using different
+languages, merge them and then make Diceware dictionary.
+
+More info about Diceware: http://world.std.com/~reinhold/diceware.html
+
+WWW: http://hg.bsdroot.lv/aldis/dicewaregen/