aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-05-13 06:06:35 +0800
committeranholt <anholt@FreeBSD.org>2003-05-13 06:06:35 +0800
commit7e12fb9f638e64c8f072a75cd817d8de97952618 (patch)
treec79a6a50449e6466c6fa9d4645d0cc04da598825 /security
parente416940be416dd38fc33cee9f4c93c2e31482ba0 (diff)
downloadfreebsd-ports-gnome-7e12fb9f638e64c8f072a75cd817d8de97952618.tar.gz
freebsd-ports-gnome-7e12fb9f638e64c8f072a75cd817d8de97952618.tar.zst
freebsd-ports-gnome-7e12fb9f638e64c8f072a75cd817d8de97952618.zip
Fix with newer gcc by converting multiline string literals to string
concatenation. Changed the formatting of the strings to what was more likely intended, so bump PORTREVISION.
Diffstat (limited to 'security')
-rw-r--r--security/fressh/Makefile1
-rw-r--r--security/fressh/files/patch-transport::ssh_deattack.c24
2 files changed, 25 insertions, 0 deletions
diff --git a/security/fressh/Makefile b/security/fressh/Makefile
index b7dbe0f26e78..9a70eb207b6e 100644
--- a/security/fressh/Makefile
+++ b/security/fressh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fressh
PORTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.fressh.org/
diff --git a/security/fressh/files/patch-transport::ssh_deattack.c b/security/fressh/files/patch-transport::ssh_deattack.c
new file mode 100644
index 000000000000..357f7ba595fd
--- /dev/null
+++ b/security/fressh/files/patch-transport::ssh_deattack.c
@@ -0,0 +1,24 @@
+--- transport/ssh_deattack.c.orig Sun May 11 22:27:05 2003
++++ transport/ssh_deattack.c Sun May 11 22:27:06 2003
+@@ -132,8 +132,8 @@
+ n = l;
+ h = (u_int32_t *) malloc(n * HASH_ENTRYSIZE);
+ if (h == NULL) {
+- SSH_ERROR("Unable to allocate memory for CRC compensation
+- attack detector: %s\n", strerror(errno));
++ SSH_ERROR("Unable to allocate memory for CRC compensation\n"
++ "attack detector: %s\n", strerror(errno));
+ return -1;
+ }
+ } else
+@@ -144,8 +144,8 @@
+ h = (u_int32_t *) realloc(h, n * HASH_ENTRYSIZE);
+
+ if (h == NULL) {
+- SSH_ERROR("Unable to allocate memory for CRC compensation
+- attack detector: %s\n", strerror(errno));
++ SSH_ERROR("Unable to allocate memory for CRC compensation\n"
++ "attack detector: %s\n", strerror(errno));
+ return -1;
+ }
+ }