aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-12-19 22:41:29 +0800
committerlinimon <linimon@FreeBSD.org>2017-12-19 22:41:29 +0800
commit81d559e229a6e0ba412844e131343f0dfc078e39 (patch)
tree9332e3d29b9f67e05c02052339c1fc25be6de3b5 /security
parent86dbf215014e2a48eec8de22391aa98bd59a3e38 (diff)
downloadfreebsd-ports-gnome-81d559e229a6e0ba412844e131343f0dfc078e39.tar.gz
freebsd-ports-gnome-81d559e229a6e0ba412844e131343f0dfc078e39.tar.zst
freebsd-ports-gnome-81d559e229a6e0ba412844e131343f0dfc078e39.zip
Mark more recently failing ports broken on aarch64.
While here, pet portlint and reformat some other BROKEN statements. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'security')
-rw-r--r--security/botan2/Makefile2
-rw-r--r--security/highwayhash/Makefile3
-rw-r--r--security/sha1collisiondetection/Makefile1
3 files changed, 5 insertions, 1 deletions
diff --git a/security/botan2/Makefile b/security/botan2/Makefile
index 19e672a014fe..f871f059a57d 100644
--- a/security/botan2/Makefile
+++ b/security/botan2/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/license.txt
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs
+BROKEN_aarch64= fails to compile: ./src/lib/block/aes/aes_armv8/aes_armv8.cpp:40:25: use of undeclared identifier 'vaeseq_u8'
+
OPTIONS_DEFINE= SQLITE3 SSL DOCS
OPTIONS_DEFAULT= SSL
OPTIONS_SUB= yes
diff --git a/security/highwayhash/Makefile b/security/highwayhash/Makefile
index 4871fe2360ea..9c99ececbb7f 100644
--- a/security/highwayhash/Makefile
+++ b/security/highwayhash/Makefile
@@ -11,7 +11,8 @@ COMMENT= Fast strong hash functions: SipHash/HighwayHash
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-ONLY_FOR_ARCHS= aarch64 amd64 powerpc powerpc64
+BROKEN_aarch64= fails to compile: /usr/lib/clang/5.0.0/include/mmintrin.h:47:5: use of undeclared identifier '__builtin_ia32_emms'
+ONLY_FOR_ARCHS= aarch64 amd64 powerpc powerpc64
ONLY_FOR_ARCHS_REASON= Assembly is implemented only for specific architectures in highwayhash/tsc_timer.h
USES= gmake
diff --git a/security/sha1collisiondetection/Makefile b/security/sha1collisiondetection/Makefile
index f49f84954031..f7574a47793f 100644
--- a/security/sha1collisiondetection/Makefile
+++ b/security/sha1collisiondetection/Makefile
@@ -11,6 +11,7 @@ COMMENT= Library and command line tool to detect SHA-1 collisions
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BROKEN_aarch64= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
BROKEN_armv6= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
BROKEN_armv7= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
BROKEN_powerpc64= fails to compile: cc1: unrecognized command line option -std=c90