aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-09-12 05:02:27 +0800
committerultima <ultima@FreeBSD.org>2017-09-12 05:02:27 +0800
commit834263b8cebe2f5ee3a548fef7f5e290f28c46cb (patch)
tree47e13d2c78d58029483e395c54a20107ee3fdfe2 /security
parent90149b94adcc2b2dca8ce981fa78009210b201bc (diff)
downloadfreebsd-ports-gnome-834263b8cebe2f5ee3a548fef7f5e290f28c46cb.tar.gz
freebsd-ports-gnome-834263b8cebe2f5ee3a548fef7f5e290f28c46cb.tar.zst
freebsd-ports-gnome-834263b8cebe2f5ee3a548fef7f5e290f28c46cb.zip
txtorcon is an implementation of the control-spec for Tor using the Twisted
networking library for Python. This is useful for writing utilities to control or make use of Tor in event-based Python programs. If your Twisted program supports endpoints (like twistd does) your server or client can make use of Tor immediately, with no code changes. Start your own Tor or connect to one and get live stream, circuit, relay updates; read and change config; monitor events; build circuits; create onion services; etcetera (ReadTheDocs). PR: 222042 Submitted by: Yuri Victorovich (maintainer) Reviewed by: lifanov (mentor), matthew (mentor), koobs Approved by: lifanov (mentor), matthew (mentor) Differential Revision: https://reviews.freebsd.org/D12311
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-txtorcon/Makefile27
-rw-r--r--security/py-txtorcon/distinfo3
-rw-r--r--security/py-txtorcon/pkg-descr11
4 files changed, 42 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3eba32307c19..f0205cf7757d 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -965,6 +965,7 @@
SUBDIR += py-tuf
SUBDIR += py-twistedConch
SUBDIR += py-twofish
+ SUBDIR += py-txtorcon
SUBDIR += py-virustotal-api
SUBDIR += py-volatility
SUBDIR += py-vulndb
diff --git a/security/py-txtorcon/Makefile b/security/py-txtorcon/Makefile
new file mode 100644
index 000000000000..efb6a81de3f4
--- /dev/null
+++ b/security/py-txtorcon/Makefile
@@ -0,0 +1,27 @@
+# Created by: Yuri Victorovich
+# $FreeBSD$
+
+PORTNAME= txtorcon
+PORTVERSION= 0.19.3
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Twisted-based Tor controller client
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twisted>=15.5.0:devel/py-twisted \
+ ${PYTHON_PKGNAMEPREFIX}ipaddress>=1.0.16:net/py-ipaddress \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=3.6.1:devel/py-zope.interface \
+ ${PYTHON_PKGNAMEPREFIX}incremental>0:devel/py-incremental \
+ ${PYTHON_PKGNAMEPREFIX}Automat>0:devel/py-Automat
+
+USES= python:2.7 shebangfix
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+SHEBANG_FILES= examples/*.py
+
+.include <bsd.port.mk>
diff --git a/security/py-txtorcon/distinfo b/security/py-txtorcon/distinfo
new file mode 100644
index 000000000000..a34ce2cda014
--- /dev/null
+++ b/security/py-txtorcon/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1504485237
+SHA256 (txtorcon-0.19.3.tar.gz) = f73396667909a3c7a98f4dd865edf4ed6a2518ee5a935d92e18b8a479ec244fd
+SIZE (txtorcon-0.19.3.tar.gz) = 265716
diff --git a/security/py-txtorcon/pkg-descr b/security/py-txtorcon/pkg-descr
new file mode 100644
index 000000000000..d278b4e3ea6f
--- /dev/null
+++ b/security/py-txtorcon/pkg-descr
@@ -0,0 +1,11 @@
+txtorcon is an implementation of the control-spec for Tor using the Twisted
+networking library for Python.
+
+This is useful for writing utilities to control or make use of Tor in
+event-based Python programs. If your Twisted program supports endpoints (like
+twistd does) your server or client can make use of Tor immediately, with no
+code changes. Start your own Tor or connect to one and get live stream, circuit,
+relay updates; read and change config; monitor events; build circuits; create
+onion services; etcetera (ReadTheDocs).
+
+WWW: https://github.com/meejah/txtorcon