aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorlifanov <lifanov@FreeBSD.org>2017-04-11 04:36:34 +0800
committerlifanov <lifanov@FreeBSD.org>2017-04-11 04:36:34 +0800
commit9195ec91eef65b6f3b3eb4d794e2c6c2a8e1d6a8 (patch)
tree34a73f246c2fe21771925f79ee8d2d8a7704a86f /security
parent87995c26d0b71ad5fac2595dcb2bc3182fb0ca93 (diff)
downloadfreebsd-ports-gnome-9195ec91eef65b6f3b3eb4d794e2c6c2a8e1d6a8.tar.gz
freebsd-ports-gnome-9195ec91eef65b6f3b3eb4d794e2c6c2a8e1d6a8.tar.zst
freebsd-ports-gnome-9195ec91eef65b6f3b3eb4d794e2c6c2a8e1d6a8.zip
add security/py-docker-pycreds
Python bindings for the docker credentials store API
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-docker-pycreds/Makefile20
-rw-r--r--security/py-docker-pycreds/distinfo3
-rw-r--r--security/py-docker-pycreds/pkg-descr3
4 files changed, 27 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c5978b0fed78..bf716740173d 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -857,6 +857,7 @@
SUBDIR += py-dfdatetime
SUBDIR += py-dfvfs
SUBDIR += py-dfwinreg
+ SUBDIR += py-docker-pycreds
SUBDIR += py-ecdsa
SUBDIR += py-ed25519ll
SUBDIR += py-fail2ban
diff --git a/security/py-docker-pycreds/Makefile b/security/py-docker-pycreds/Makefile
new file mode 100644
index 000000000000..c117514f4714
--- /dev/null
+++ b/security/py-docker-pycreds/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= docker-pycreds
+PORTVERSION= 0.2.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lifanov@FreeBSD.org
+COMMENT= Python bindings for the docker credentials store API
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.4:devel/py-six
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/security/py-docker-pycreds/distinfo b/security/py-docker-pycreds/distinfo
new file mode 100644
index 000000000000..82fb8e174565
--- /dev/null
+++ b/security/py-docker-pycreds/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1491855655
+SHA256 (docker-pycreds-0.2.1.tar.gz) = 93833a2cf280b7d8abbe1b8121530413250c6cd4ffed2c1cf085f335262f7348
+SIZE (docker-pycreds-0.2.1.tar.gz) = 7555
diff --git a/security/py-docker-pycreds/pkg-descr b/security/py-docker-pycreds/pkg-descr
new file mode 100644
index 000000000000..695086e0be6f
--- /dev/null
+++ b/security/py-docker-pycreds/pkg-descr
@@ -0,0 +1,3 @@
+Python bindings for the docker credentials store API
+
+WWW: https://github.com/shin-/dockerpy-creds/