aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoralfred <alfred@FreeBSD.org>2001-02-10 09:30:47 +0800
committeralfred <alfred@FreeBSD.org>2001-02-10 09:30:47 +0800
commit9e63263bf9aebc5239140869678deda69103a7d8 (patch)
tree2a6098a31b18cf2e610bf7a96265bcd0a4b9837c /security
parent96d7a7fd89d4a3eb43d8f378d8c9782a11d2562f (diff)
downloadfreebsd-ports-gnome-9e63263bf9aebc5239140869678deda69103a7d8.tar.gz
freebsd-ports-gnome-9e63263bf9aebc5239140869678deda69103a7d8.tar.zst
freebsd-ports-gnome-9e63263bf9aebc5239140869678deda69103a7d8.zip
give aout machines shared libraries as well
Diffstat (limited to 'security')
-rw-r--r--security/openssl-beta/Makefile5
-rw-r--r--security/openssl-beta/files/patch-ab2
-rw-r--r--security/openssl/Makefile5
-rw-r--r--security/openssl/files/patch-ab2
4 files changed, 10 insertions, 4 deletions
diff --git a/security/openssl-beta/Makefile b/security/openssl-beta/Makefile
index 483fa23bc12b..6cac3da487e8 100644
--- a/security/openssl-beta/Makefile
+++ b/security/openssl-beta/Makefile
@@ -20,8 +20,11 @@ MAINTAINER= dirk@FreeBSD.org
.if ${OSVERSION} >= 400014
FORBIDDEN= "OpenSSL is already in the base system"
.endif
+
.if ${PORTOBJFORMAT} == "aout"
-NOSHARED= yes
+MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=-Bforcearchive
+.else
+MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
.endif
USE_PERL5= yes
diff --git a/security/openssl-beta/files/patch-ab b/security/openssl-beta/files/patch-ab
index b043ccd35bd2..8ad463b64eed 100644
--- a/security/openssl-beta/files/patch-ab
+++ b/security/openssl-beta/files/patch-ab
@@ -22,7 +22,7 @@
+ ${MAKE} CC='${CC}' PLATFORM='${PLATFORM}' CFLAG='-fPIC ${CFLAG}' SDIRS='${SDIRS}' INSTALLTOP='${INSTALLTOP}' PEX_LIBS='${PEX_LIBS}' EX_LIBS='${EX_LIBS}' BN_ASM='${BN_ASM}' DES_ENC='${DES_ENC}' BF_ENC='${BF_ENC}' CAST_ENC='${CAST_ENC}' RC4_ENC='${RC4_ENC}' RC5_ENC='${RC5_ENC}' SHA1_ASM_OBJ='${SHA1_ASM_OBJ}' MD5_ASM_OBJ='${MD5_ASM_OBJ}' RMD160_ASM_OBJ='${RMD160_ASM_OBJ}' AR='${AR}' DIRS=$$i clean all || exit 1; \
+ ( set -x; ${CC} -shared -o lib$$i.so.${SHLIBVER} \
+ -Wl,-S,-soname=lib$$i.so.${SHLIBVER} \
-+ -Wl,--whole-archive lib$$i.a ) || exit 1; \
++ -Wl,${WHOLE_ARCHIVE_FLAG} lib$$i.a ) || exit 1; \
+ rm -f lib$$i.a; (cd $$i ; ${MAKE} clean) || exit 1 ;\
+ done;
+ @set -x; \
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 483fa23bc12b..6cac3da487e8 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -20,8 +20,11 @@ MAINTAINER= dirk@FreeBSD.org
.if ${OSVERSION} >= 400014
FORBIDDEN= "OpenSSL is already in the base system"
.endif
+
.if ${PORTOBJFORMAT} == "aout"
-NOSHARED= yes
+MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=-Bforcearchive
+.else
+MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
.endif
USE_PERL5= yes
diff --git a/security/openssl/files/patch-ab b/security/openssl/files/patch-ab
index b043ccd35bd2..8ad463b64eed 100644
--- a/security/openssl/files/patch-ab
+++ b/security/openssl/files/patch-ab
@@ -22,7 +22,7 @@
+ ${MAKE} CC='${CC}' PLATFORM='${PLATFORM}' CFLAG='-fPIC ${CFLAG}' SDIRS='${SDIRS}' INSTALLTOP='${INSTALLTOP}' PEX_LIBS='${PEX_LIBS}' EX_LIBS='${EX_LIBS}' BN_ASM='${BN_ASM}' DES_ENC='${DES_ENC}' BF_ENC='${BF_ENC}' CAST_ENC='${CAST_ENC}' RC4_ENC='${RC4_ENC}' RC5_ENC='${RC5_ENC}' SHA1_ASM_OBJ='${SHA1_ASM_OBJ}' MD5_ASM_OBJ='${MD5_ASM_OBJ}' RMD160_ASM_OBJ='${RMD160_ASM_OBJ}' AR='${AR}' DIRS=$$i clean all || exit 1; \
+ ( set -x; ${CC} -shared -o lib$$i.so.${SHLIBVER} \
+ -Wl,-S,-soname=lib$$i.so.${SHLIBVER} \
-+ -Wl,--whole-archive lib$$i.a ) || exit 1; \
++ -Wl,${WHOLE_ARCHIVE_FLAG} lib$$i.a ) || exit 1; \
+ rm -f lib$$i.a; (cd $$i ; ${MAKE} clean) || exit 1 ;\
+ done;
+ @set -x; \