aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2017-05-06 15:38:46 +0800
committermiwi <miwi@FreeBSD.org>2017-05-06 15:38:46 +0800
commit9ee5a28bcbd5245642ceb8573f2dcb56f1031d7f (patch)
tree78e20ba9b242ad1773bc36301dc4755b5afda376 /security
parent7f405e9fa8fa9e30963f7581f5bf0190f382122f (diff)
downloadfreebsd-ports-gnome-9ee5a28bcbd5245642ceb8573f2dcb56f1031d7f.tar.gz
freebsd-ports-gnome-9ee5a28bcbd5245642ceb8573f2dcb56f1031d7f.tar.zst
freebsd-ports-gnome-9ee5a28bcbd5245642ceb8573f2dcb56f1031d7f.zip
The python binding of the cryptographic library cryptlib.
WWW: http://www.cs.auckland.ac.nz/~pgut001/cryptlib/ PR: 216011 Submitted by: Yuri Victorovich <yuri@rawbw.com>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-cryptlib_py/Makefile28
-rw-r--r--security/py-cryptlib_py/distinfo3
-rw-r--r--security/py-cryptlib_py/pkg-descr3
4 files changed, 35 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 74d992524017..b23c045feca0 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -849,6 +849,7 @@
SUBDIR += py-cpe
SUBDIR += py-cracklib
SUBDIR += py-cryptkit
+ SUBDIR += py-cryptlib_py
SUBDIR += py-cryptography
SUBDIR += py-cybox
SUBDIR += py-dfdatetime
diff --git a/security/py-cryptlib_py/Makefile b/security/py-cryptlib_py/Makefile
new file mode 100644
index 000000000000..6c2e25932abb
--- /dev/null
+++ b/security/py-cryptlib_py/Makefile
@@ -0,0 +1,28 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= cryptlib_py
+PORTVERSION= 3.4.3
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.franken.de/pub/crypt/cryptlib/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= cl${PORTVERSION:S/.//g}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Pythin binding for cryptlib
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+ONLY_FOR_ARCHS= i386 amd64 armv6
+
+USES= python:2 zip:infozip
+USE_PYTHON= distutils autoplist
+
+LIB_DEPENDS+= libcl.so:security/cryptlib
+
+BUILD_WRKSRC= ${WRKSRC}/bindings
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+NO_WRKSUBDIR= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-cryptlib_py/distinfo b/security/py-cryptlib_py/distinfo
new file mode 100644
index 000000000000..09831e289697
--- /dev/null
+++ b/security/py-cryptlib_py/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1484269132
+SHA256 (cl343.zip) = 08b104442bb5c7281a3299853d5585cc63bd928454dff3150569c02b957427ad
+SIZE (cl343.zip) = 5703258
diff --git a/security/py-cryptlib_py/pkg-descr b/security/py-cryptlib_py/pkg-descr
new file mode 100644
index 000000000000..479ba39bbffe
--- /dev/null
+++ b/security/py-cryptlib_py/pkg-descr
@@ -0,0 +1,3 @@
+The python binding of the cryptographic library cryptlib.
+
+WWW: http://www.cs.auckland.ac.nz/~pgut001/cryptlib/