aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-16 21:23:13 +0800
committermat <mat@FreeBSD.org>2016-06-16 21:23:13 +0800
commita4af234af8f51d40eb998ed6d368ccea401a3302 (patch)
treef5237f7173e7b9a5cbac11e6a57f460d84e79314 /security
parent56be8553fe553c4526347278fbdd90ec4156eb14 (diff)
downloadfreebsd-ports-gnome-a4af234af8f51d40eb998ed6d368ccea401a3302.tar.gz
freebsd-ports-gnome-a4af234af8f51d40eb998ed6d368ccea401a3302.tar.zst
freebsd-ports-gnome-a4af234af8f51d40eb998ed6d368ccea401a3302.zip
Fix usage of WITH_OPENSSL_BASE, WITH_OPENSSL_PORT and OPENSSL_PORT.
WITH_OPENSSL_* can't be set after bsd.port.pre.mk. Fold all other usage into using SSL_DEFAULT == foo PR: 210149 Submitted by: mat Exp-run by: antoine Sponsored by: The FreeBSD Foundation, Absolight Differential Revision: https://reviews.freebsd.org/D6577
Diffstat (limited to 'security')
-rw-r--r--security/R-cran-openssl/Makefile4
-rw-r--r--security/bro/Makefile4
-rw-r--r--security/hpenc/Makefile11
-rw-r--r--security/libssh2/Makefile2
-rw-r--r--security/p5-openxpki/Makefile2
-rw-r--r--security/pam_ocra/Makefile11
-rw-r--r--security/py-m2crypto/Makefile2
-rw-r--r--security/s2n/Makefile6
-rw-r--r--security/softhsm2/Makefile6
-rw-r--r--security/stunnel/Makefile8
10 files changed, 24 insertions, 32 deletions
diff --git a/security/R-cran-openssl/Makefile b/security/R-cran-openssl/Makefile
index 59f7bea4be19..f058add67d95 100644
--- a/security/R-cran-openssl/Makefile
+++ b/security/R-cran-openssl/Makefile
@@ -13,7 +13,7 @@ LICENSE= MIT
USES= cran:auto-plist
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000015
WITH_OPENSSL_PORT= yes
@@ -21,4 +21,4 @@ R_POSTCMD_INSTALL_OPTIONS+= --configure-vars="INCLUDE_DIR=${OPENSSLINC} LIB_DIR=
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/bro/Makefile b/security/bro/Makefile
index efdc80755d6c..c4b6be8228f4 100644
--- a/security/bro/Makefile
+++ b/security/bro/Makefile
@@ -137,8 +137,8 @@ CMAKE_ARGS+= -D CMAKE_EXE_LINKER_FLAGS="${OPENSSL_LDFLAGS}"
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcrypto.so:security/openssl
RUN_DEPENDS+= ${LOCALBASE}/lib/libcrypto.so:security/openssl
.else
-.if defined(WITH_OPENSSL_PORT)
-IGNORE= the SSL option is requred when WITH_OPENSSL_PORT is enabled
+.if ${SSL_DEFAULT} != base
+IGNORE= the SSL option is requred when using SSL from ports
.endif
.endif
diff --git a/security/hpenc/Makefile b/security/hpenc/Makefile
index ce9ef1b50ebe..80ed20b43aee 100644
--- a/security/hpenc/Makefile
+++ b/security/hpenc/Makefile
@@ -28,21 +28,14 @@ CXXFLAGS+= -std=c++11 \
-I${OPENSSLINC}
LDFLAGS+= -pthread -lcrypto -L${OPENSSLLIB}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000036
WITH_OPENSSL_PORT= yes
-
-# XXX: brain damage warning
-# we need to .include bsd.openssl.mk manually here.because USE_OPENSSL only
-# works when it is defined before bsd.port{.pre}.mk is .included.
-# This makes it currently impossible to combine this macro with OSVERSION to
-# conditionally select WITH_OPENSSL_PORT for OSVERSIONS before 1000015
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
.endif
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/hpenc.1 ${STAGEDIR}${MANPREFIX}/man/man1
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/hpenc
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/libssh2/Makefile b/security/libssh2/Makefile
index 06579114ec97..54ef09474992 100644
--- a/security/libssh2/Makefile
+++ b/security/libssh2/Makefile
@@ -43,7 +43,7 @@ USE_OPENSSL= yes
post-patch:
@${REINPLACE_CMD} -e '/Libs:/s/@LDFLAGS@//' -e '/Libs:/s/@LIBS@//' \
${WRKSRC}/libssh2.pc.in
-.if defined(WITH_OPENSSL_BASE)
+.if ${SSL_DEFAULT} == base
@${REINPLACE_CMD} -e 's/LIBSREQUIRED=libssl,libcrypto/LIBS="$$LIBS -lssl -lcrypto"/' \
${WRKSRC}/configure
.endif
diff --git a/security/p5-openxpki/Makefile b/security/p5-openxpki/Makefile
index 6d48f893c9cc..973ff2c74bc2 100644
--- a/security/p5-openxpki/Makefile
+++ b/security/p5-openxpki/Makefile
@@ -114,7 +114,7 @@ post-stage:
.include <bsd.port.pre.mk>
-.if defined(WITH_OPENSSL_PORT) && defined(OPENSSL_PORT) && ${OPENSSL_PORT} == security/libressl
+.if ${SSL_DEFAULT} == libressl
IGNORE= this version of OpenXPKI is not fully functional with LibreSSL library, use OpenSSL instead
.endif
diff --git a/security/pam_ocra/Makefile b/security/pam_ocra/Makefile
index e5756951b815..22134d709612 100644
--- a/security/pam_ocra/Makefile
+++ b/security/pam_ocra/Makefile
@@ -11,6 +11,7 @@ COMMENT= RFC6287 (OCRA) PAM module
LICENSE= BSD2CLAUSE
USES= uidfix
+USE_OPENSSL= yes
USE_GITHUB= yes
@@ -22,7 +23,7 @@ PLIST_FILES= lib/pam_ocra.so \
man/man8/pam_ocra.8.gz \
man/man8/ocra_tool.8.gz
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000015
WITH_OPENSSL_PORT= yes
@@ -30,10 +31,4 @@ CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
.endif
-# we need to .include bsd.openssl.mk manually here.because USE_OPENSSL only
-# works when it is defined before bsd.port{.pre}.mk is .included.
-# This makes it currently impossible to combine this macro with OSVERSION to
-# conditionally select WITH_OPENSSL_PORT for OSVERSIONS before 1000015.
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/py-m2crypto/Makefile b/security/py-m2crypto/Makefile
index f427a08f8a50..1cb6ffd06b16 100644
--- a/security/py-m2crypto/Makefile
+++ b/security/py-m2crypto/Makefile
@@ -27,7 +27,7 @@ PLIST_FILES= %%PYTHON_SITELIBDIR%%/M2Crypto/_m2crypto.py \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 1000000 && !defined(WITH_OPENSSL_PORT)
+.if ${OSVERSION} < 1000000 && ${SSL_DEFAULT} == base
IGNORE= py-m2crypto requires OpenSSL 1.0.1e+
.endif
diff --git a/security/s2n/Makefile b/security/s2n/Makefile
index 4906c583b948..2a09e79fc592 100644
--- a/security/s2n/Makefile
+++ b/security/s2n/Makefile
@@ -17,17 +17,17 @@ GH_TAGNAME= c6da8bb
OPTIONS_DEFINE= DOCS EXAMPLES
USES= gmake
+USE_OPENSSL=yes
USE_LDCONFIG= yes
NO_CONFIGURE= yes
SUB_FILES= pkg-message Makefile
ALL_TARGET= bin
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000015
WITH_OPENSSL_PORT= yes
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
.endif
@@ -50,4 +50,4 @@ do-install:
tests: build
${GMAKE} PLATFORM=FreeBSD CRYPTO_LDFLAGS=-L${LOCALBASE}/lib -C ${WRKSRC}/tests
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/softhsm2/Makefile b/security/softhsm2/Makefile
index a519524e3411..3bf3a486159f 100644
--- a/security/softhsm2/Makefile
+++ b/security/softhsm2/Makefile
@@ -38,8 +38,10 @@ CRYP_OPEN_USE= openssl=yes
CRYP_OPEN_VARS= WITH_OPENSSL_PORT=yes
CRYP_OPEN_CONFIGURE_ON= --with-crypto-backend=openssl
-.if defined(OPENSSL_PORT) && ${OPENSSL_PORT} == security/libressl
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT} == libressl
CONFIGURE_ARGS+= --disable-gost
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index aaeaed8c5727..1f0a8ceebfbd 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -74,11 +74,13 @@ CONFIGURE_ARGS+=--with-threads=pthread
LDFLAGS+= -lpthread
.endif
-.if ${PORT_OPTIONS:MFIPS} && defined(OPENSSL_PORT) && ${OPENSSL_PORT} == security/libressl
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MFIPS} && ${SSL_DEFAULT} == libressl
IGNORE= LibreSSL does not support FIPS standard
.endif
-.if defined(OPENSSL_PORT) && ${OPENSSL_PORT} == security/libressl
+.if ${SSL_DEFAULT} == libressl
NO_PACKAGE= The stunnel license restricts distribution when linked to non-OpenSSL non-base SSL-libraries
.endif
@@ -115,4 +117,4 @@ cert:
@${ECHO} ""
@(cd ${WRKSRC}/tools/; make install-data-local)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>