aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbrd <brd@FreeBSD.org>2016-05-19 22:31:37 +0800
committerbrd <brd@FreeBSD.org>2016-05-19 22:31:37 +0800
commitb02517ddf76d3533693777bb0614fbde854d5f23 (patch)
tree6559a645747fa84b062c6dc4ed25e5d592c8122e /security
parent01ba9fc1656c256ebde2a3b633c5ffe77ccff1b8 (diff)
downloadfreebsd-ports-gnome-b02517ddf76d3533693777bb0614fbde854d5f23.tar.gz
freebsd-ports-gnome-b02517ddf76d3533693777bb0614fbde854d5f23.tar.zst
freebsd-ports-gnome-b02517ddf76d3533693777bb0614fbde854d5f23.zip
Add a new port security/rubygem-digest-crc.
Approved by: swills (mentor)
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-digest-crc/Makefile17
-rw-r--r--security/rubygem-digest-crc/distinfo3
-rw-r--r--security/rubygem-digest-crc/pkg-descr4
4 files changed, 25 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c69a483ae626..929cb4f40b27 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -967,6 +967,7 @@
SUBDIR += rubygem-bcrypt
SUBDIR += rubygem-bcrypt-ruby
SUBDIR += rubygem-devise-two-factor
+ SUBDIR += rubygem-digest-crc
SUBDIR += rubygem-doorkeeper
SUBDIR += rubygem-encryptor
SUBDIR += rubygem-ezcrypto
diff --git a/security/rubygem-digest-crc/Makefile b/security/rubygem-digest-crc/Makefile
new file mode 100644
index 000000000000..ba0b3fc3b42f
--- /dev/null
+++ b/security/rubygem-digest-crc/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= digest-crc
+PORTVERSION= 0.4.1
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Adds support for CRC to the Digest module
+
+LICENSE= MIT
+
+USE_RUBY= yes
+USES= gem
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-digest-crc/distinfo b/security/rubygem-digest-crc/distinfo
new file mode 100644
index 000000000000..366165d57aa5
--- /dev/null
+++ b/security/rubygem-digest-crc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1463609107
+SHA256 (rubygem/digest-crc-0.4.1.gem) = 1494ee18bbb84a61828afe09616dc22c2b73a492b50b0f79334a85321db80823
+SIZE (rubygem/digest-crc-0.4.1.gem) = 22528
diff --git a/security/rubygem-digest-crc/pkg-descr b/security/rubygem-digest-crc/pkg-descr
new file mode 100644
index 000000000000..a9d202f8a03b
--- /dev/null
+++ b/security/rubygem-digest-crc/pkg-descr
@@ -0,0 +1,4 @@
+Adds support for calculating Cyclic Redundancy Check (CRC) to the Digest module.
+Pure Ruby implementation. Provides CRC Tables for optimized calculations.
+
+WWW: https://github.com/postmodern/digest-crc