aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-05-24 08:33:07 +0800
committerwen <wen@FreeBSD.org>2010-05-24 08:33:07 +0800
commitca9e67d2dc5dcda6ea3b36425ab9ef0822a43ab3 (patch)
tree14249ea6f99cbd262a721c52e7a43824d62def1e /security
parent0ef7df06a1343ca11978a4356923f4a764bd333c (diff)
downloadfreebsd-ports-gnome-ca9e67d2dc5dcda6ea3b36425ab9ef0822a43ab3.tar.gz
freebsd-ports-gnome-ca9e67d2dc5dcda6ea3b36425ab9ef0822a43ab3.tar.zst
freebsd-ports-gnome-ca9e67d2dc5dcda6ea3b36425ab9ef0822a43ab3.zip
The Tiny Encryption Algorithm in Perl and JavaScript.
WWW: http://search.cpan.org/~pjb/Crypt-Tea/ PR: ports/145303 Submitted by: Steve Wills <steve@mouf.net>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-T_e_a/Makefile24
-rw-r--r--security/p5-Crypt-T_e_a/distinfo3
-rw-r--r--security/p5-Crypt-T_e_a/pkg-descr3
-rw-r--r--security/p5-Crypt-T_e_a/pkg-plist6
5 files changed, 37 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 6e370479f39d..75c31c1a294b 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -468,6 +468,7 @@
SUBDIR += p5-Crypt-SmbHash
SUBDIR += p5-Crypt-Solitaire
SUBDIR += p5-Crypt-TEA
+ SUBDIR += p5-Crypt-T_e_a
SUBDIR += p5-Crypt-TripleDES
SUBDIR += p5-Crypt-Twofish
SUBDIR += p5-Crypt-Twofish2
diff --git a/security/p5-Crypt-T_e_a/Makefile b/security/p5-Crypt-T_e_a/Makefile
new file mode 100644
index 000000000000..8b6cc05f7b13
--- /dev/null
+++ b/security/p5-Crypt-T_e_a/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Crypt-T_e_a
+# Date created: 2010-03-11
+# Whom: Steve Wills <steve@mouf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-T_e_a
+PORTVERSION= 2.12
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/P/PJ/PJB
+PKGNAMEPREFIX= p5-
+DISTNAME= Crypt-Tea-${PORTVERSION}
+
+MAINTAINER= steve@mouf.net
+COMMENT= The Tiny Encryption Algorithm in Perl and JavaScript
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Tea.3
+MAN1= tea.1
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-T_e_a/distinfo b/security/p5-Crypt-T_e_a/distinfo
new file mode 100644
index 000000000000..4ed3759131ce
--- /dev/null
+++ b/security/p5-Crypt-T_e_a/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-Tea-2.12.tar.gz) = 29eb004d5059adaafc9c83dfb948dd11
+SHA256 (Crypt-Tea-2.12.tar.gz) = f38c56c25fc1483714d66e2239acb2c8bba7698d7d58a78af7a43c8be89dabd8
+SIZE (Crypt-Tea-2.12.tar.gz) = 28109
diff --git a/security/p5-Crypt-T_e_a/pkg-descr b/security/p5-Crypt-T_e_a/pkg-descr
new file mode 100644
index 000000000000..cd230963a50f
--- /dev/null
+++ b/security/p5-Crypt-T_e_a/pkg-descr
@@ -0,0 +1,3 @@
+The Tiny Encryption Algorithm in Perl and JavaScript.
+
+WWW: http://search.cpan.org/~pjb/Crypt-Tea/
diff --git a/security/p5-Crypt-T_e_a/pkg-plist b/security/p5-Crypt-T_e_a/pkg-plist
new file mode 100644
index 000000000000..74b0c4a73696
--- /dev/null
+++ b/security/p5-Crypt-T_e_a/pkg-plist
@@ -0,0 +1,6 @@
+bin/tea
+%%SITE_PERL%%/Crypt/Tea.pm
+%%SITE_PERL%%/mach/auto/Crypt/Tea/.packlist
+@dirrmtry %%SITE_PERL%%/mach/auto/Crypt/Tea
+@dirrmtry %%SITE_PERL%%/mach/auto/Crypt
+@dirrmtry %%SITE_PERL%%/Crypt