aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-08-18 18:12:33 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-08-18 18:12:33 +0800
commitce3e645ae53e7cee63844e7d7d9c34944fe41782 (patch)
tree45aa280f72cec1a809419c58600a674a2b6d08b2 /security
parent3d595f3c248bac678191c251134c217818a45e3f (diff)
downloadfreebsd-ports-gnome-ce3e645ae53e7cee63844e7d7d9c34944fe41782.tar.gz
freebsd-ports-gnome-ce3e645ae53e7cee63844e7d7d9c34944fe41782.tar.zst
freebsd-ports-gnome-ce3e645ae53e7cee63844e7d7d9c34944fe41782.zip
- Update to 2.9.0
- Switch to USES=ssl
Diffstat (limited to 'security')
-rw-r--r--security/i2pd/Makefile7
-rw-r--r--security/i2pd/distinfo6
-rw-r--r--security/i2pd/files/patch-httpparser49
3 files changed, 6 insertions, 56 deletions
diff --git a/security/i2pd/Makefile b/security/i2pd/Makefile
index 218b40d3b0f6..6e396e3e11f8 100644
--- a/security/i2pd/Makefile
+++ b/security/i2pd/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= i2pd
-PORTVERSION= 2.7.0
+PORTVERSION= 2.9.0
CATEGORIES= security net-p2p
MAINTAINER= amdmi3@FreeBSD.org
@@ -13,15 +13,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= does not build
BROKEN_FreeBSD_9= does not build
USE_GITHUB= yes
GH_ACCOUNT= PurpleI2P
-USES= cmake compiler:c++11-lib
+USES= cmake compiler:c++11-lib ssl
CMAKE_SOURCE_PATH=${WRKSRC}/build
-USE_OPENSSL= yes
PLIST_FILES= bin/${PORTNAME} \
man/man1/${PORTNAME}.1.gz
diff --git a/security/i2pd/distinfo b/security/i2pd/distinfo
index e9e4082f4f8a..7b3930f8f8e1 100644
--- a/security/i2pd/distinfo
+++ b/security/i2pd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1464019672
-SHA256 (PurpleI2P-i2pd-2.7.0_GH0.tar.gz) = e4a3e192e424492962092f65a04fe12cac10f267ba2c99e2e62ca917741fba7e
-SIZE (PurpleI2P-i2pd-2.7.0_GH0.tar.gz) = 410922
+TIMESTAMP = 1471280887
+SHA256 (PurpleI2P-i2pd-2.9.0_GH0.tar.gz) = 48139f83352f26023b99d7d6ee49e648febd2a8db6beb88c108facaf46a282e2
+SIZE (PurpleI2P-i2pd-2.9.0_GH0.tar.gz) = 2967757
diff --git a/security/i2pd/files/patch-httpparser b/security/i2pd/files/patch-httpparser
deleted file mode 100644
index a48fee8952a2..000000000000
--- a/security/i2pd/files/patch-httpparser
+++ /dev/null
@@ -1,49 +0,0 @@
-commit 43a90d7b98b1b317022f468bcf23027e039142fe
-Author: hagen <hagen@mail.i2p>
-Date: Thu May 26 00:00:00 2016 +0000
-
- * HTTP.cpp : fix parse_header_line (#501)
-
-diff --git HTTP.cpp HTTP.cpp
-index 83f1ac3..66dbc76 100644
---- HTTP.cpp
-+++ HTTP.cpp
-@@ -45,9 +45,10 @@ namespace http {
- bool parse_header_line(const std::string & line, std::map<std::string, std::string> & headers) {
- std::size_t pos = 0;
- std::size_t len = 2; /* strlen(": ") */
-+ std::size_t max = line.length();
- if ((pos = line.find(": ", pos)) == std::string::npos)
- return false;
-- while (isspace(line.at(pos + len)))
-+ while ((pos + len) < max && isspace(line.at(pos + len)))
- len++;
- std::string name = line.substr(0, pos);
- std::string value = line.substr(pos + len);
-diff --git tests/test-http-req.cpp tests/test-http-req.cpp
-index 10ea621..d536262 100644
---- tests/test-http-req.cpp
-+++ tests/test-http-req.cpp
-@@ -68,6 +68,7 @@ int main() {
- buf =
- "GET http://inr.i2p HTTP/1.1\r\n"
- "Host: stats.i2p\r\n"
-+ "Accept-Encoding: \r\n"
- "Accept: */*\r\n"
- "\r\n";
- len = strlen(buf);
-@@ -76,9 +77,13 @@ int main() {
- assert(req->method == "GET");
- assert(req->uri == "http://inr.i2p");
- assert(req->host == "stats.i2p");
-- assert(req->headers.size() == 2);
-+ assert(req->headers.size() == 3);
- assert(req->headers.count("Host") == 1);
- assert(req->headers.count("Accept") == 1);
-+ assert(req->headers.count("Accept-Encoding") == 1);
-+ assert(req->headers["Host"] == "stats.i2p");
-+ assert(req->headers["Accept"] == "*/*");
-+ assert(req->headers["Accept-Encoding"] == "");
- delete req;
-
- return 0;