aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>2002-01-01 08:05:56 +0800
committerjmz <jmz@FreeBSD.org>2002-01-01 08:05:56 +0800
commitd01826b388f2c2a4fb1aa7943f89ba9946554f3d (patch)
tree24a92aff09651700f6840e9e84aa9b9fd5ba55b0 /security
parent654c82fa49ef8335c99483835fa99c0428ac00a7 (diff)
downloadfreebsd-ports-gnome-d01826b388f2c2a4fb1aa7943f89ba9946554f3d.tar.gz
freebsd-ports-gnome-d01826b388f2c2a4fb1aa7943f89ba9946554f3d.tar.zst
freebsd-ports-gnome-d01826b388f2c2a4fb1aa7943f89ba9946554f3d.zip
SubWeb is a (reverse) proxy to inspect HTTP flows on the fly
PR: ports/33388 Submitted by: Nicolas Jombart <Nicolas.Jombart@hsc-labs.com>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/subweb/Makefile24
-rw-r--r--security/subweb/distinfo1
-rw-r--r--security/subweb/pkg-comment1
-rw-r--r--security/subweb/pkg-descr14
-rw-r--r--security/subweb/pkg-plist3
6 files changed, 44 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 7d4f45f970c7..56cb599e76f5 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -220,6 +220,7 @@
SUBDIR += steghide
SUBDIR += strobe
SUBDIR += stunnel
+ SUBDIR += subweb
SUBDIR += sudo
SUBDIR += super
SUBDIR += swatch
diff --git a/security/subweb/Makefile b/security/subweb/Makefile
new file mode 100644
index 000000000000..0051b92b51cc
--- /dev/null
+++ b/security/subweb/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: subweb
+# Date created: december 30, 2001
+# Whom: Nicolas Jombart <Nicolas.Jombart@hsc-labs.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= subweb
+PORTVERSION= 1.0
+CATEGORIES= security www
+MASTER_SITES= http://www.hsc.fr/ressources/outils/subweb/download/
+
+MAINTAINER= Nicolas.Jombart@hsc-labs.com
+
+NO_BUILD= YES
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/subweb ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/subweb
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/subweb
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/subweb/distinfo b/security/subweb/distinfo
new file mode 100644
index 000000000000..48a621327405
--- /dev/null
+++ b/security/subweb/distinfo
@@ -0,0 +1 @@
+MD5 (subweb-1.0.tar.gz) = fbbca913a6fb12ff82f2d8139fc4a97e
diff --git a/security/subweb/pkg-comment b/security/subweb/pkg-comment
new file mode 100644
index 000000000000..bfd4dac387c1
--- /dev/null
+++ b/security/subweb/pkg-comment
@@ -0,0 +1 @@
+SubWeb is a (reverse) proxy to inspect HTTP flows on the fly
diff --git a/security/subweb/pkg-descr b/security/subweb/pkg-descr
new file mode 100644
index 000000000000..dcf7a0b3fb10
--- /dev/null
+++ b/security/subweb/pkg-descr
@@ -0,0 +1,14 @@
+SubWeb is a proxy/reverse proxy for HTTP flows. It is possible
+with SubWeb to handle and visualize HTTP request, headers, body
+on the fly.
+
+It has three operating modes : proxy, reverse proxy, and midproxy
+(a proxy which requires the pages from another proxy). It can
+also act as a virtual web server, i.e. answer certain request
+based on keyword match.
+
+SubWeb can also allow filtering, and is highly customizable.
+
+WWW: http://www.hsc-labs.com/tools/subweb/
+
+-- Nicolas Jombart <Nicolas.Jombart@hsc-labs.com>
diff --git a/security/subweb/pkg-plist b/security/subweb/pkg-plist
new file mode 100644
index 000000000000..3a6db53f7093
--- /dev/null
+++ b/security/subweb/pkg-plist
@@ -0,0 +1,3 @@
+bin/subweb
+%%PORTDOCS%%share/doc/subweb/README
+%%PORTDOCS%%@dirrm share/doc/subweb