aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2017-04-23 06:36:49 +0800
committerjrm <jrm@FreeBSD.org>2017-04-23 06:36:49 +0800
commitde0fe71f1b9cd322016a45fae8cacad7219fc389 (patch)
treed99e3d83641229f0b0b08d073d8021d0427806dc /security
parent1abf470a78d8f880efbc8e9819108036ca948d43 (diff)
downloadfreebsd-ports-gnome-de0fe71f1b9cd322016a45fae8cacad7219fc389.tar.gz
freebsd-ports-gnome-de0fe71f1b9cd322016a45fae8cacad7219fc389.tar.zst
freebsd-ports-gnome-de0fe71f1b9cd322016a45fae8cacad7219fc389.zip
New port, security/rubygem-openssl: Gem that wraps around OpenSSL library
While there is an OpenSSL gem packaged with Ruby, a separate gem has been created, so that when OpenSSL security issues arise, the separate gem can be released independently of Ruby. WWW: https://github.com/ruby/openssl/ Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D10415
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-openssl/Makefile19
-rw-r--r--security/rubygem-openssl/distinfo3
-rw-r--r--security/rubygem-openssl/pkg-descr4
4 files changed, 27 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 704f6c5987d5..04d41de336cd 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1036,6 +1036,7 @@
SUBDIR += rubygem-omniauth-oauth2-generic
SUBDIR += rubygem-omniauth-saml
SUBDIR += rubygem-omniauth-shibboleth
+ SUBDIR += rubygem-openssl
SUBDIR += rubygem-openssl-ccm
SUBDIR += rubygem-openvas-omp
SUBDIR += rubygem-origami
diff --git a/security/rubygem-openssl/Makefile b/security/rubygem-openssl/Makefile
new file mode 100644
index 000000000000..eba1d1bdd030
--- /dev/null
+++ b/security/rubygem-openssl/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= openssl
+PORTVERSION= 2.0.3
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby gem that wraps around the OpenSSL library
+
+LICENSE= BSD2CLAUSE RUBY
+LICENSE_COMB= dual
+LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/BSDL
+LICENSE_FILE_RUBY= ${WRKSRC}/LICENSE.txt
+
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-openssl/distinfo b/security/rubygem-openssl/distinfo
new file mode 100644
index 000000000000..2eb7778e62a5
--- /dev/null
+++ b/security/rubygem-openssl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492469369
+SHA256 (rubygem/openssl-2.0.3.gem) = d6eb36bbe612c0ffa036da6fe4e664ea92d292df30f823ad5d571c936f5015d6
+SIZE (rubygem/openssl-2.0.3.gem) = 167424
diff --git a/security/rubygem-openssl/pkg-descr b/security/rubygem-openssl/pkg-descr
new file mode 100644
index 000000000000..dc411ac8c5e2
--- /dev/null
+++ b/security/rubygem-openssl/pkg-descr
@@ -0,0 +1,4 @@
+OpenSSL provides SSL, TLS and general purpose cryptography. This gem wraps the
+OpenSSL library.
+
+WWW: https://ruby.github.io/openssl/