aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2011-04-06 17:42:40 +0800
committerale <ale@FreeBSD.org>2011-04-06 17:42:40 +0800
commite0625fb61aa3b4017ecc22690e066b54b9ebaa4d (patch)
treee22d470559064e2c34689bec00b21097f92b4248 /security
parent9133a0fc44782e331d347765b79280ebdea3cc99 (diff)
downloadfreebsd-ports-gnome-e0625fb61aa3b4017ecc22690e066b54b9ebaa4d.tar.gz
freebsd-ports-gnome-e0625fb61aa3b4017ecc22690e066b54b9ebaa4d.tar.zst
freebsd-ports-gnome-e0625fb61aa3b4017ecc22690e066b54b9ebaa4d.zip
pkcs11-gateway is a software that allows you to use a Linux 32-bit PKCS#11
module on FreeBSD i386/amd64. It consists of a FreeBSD Cryptoki wrapper library that serializes and forwards PKCS#11 function calls to a Linux server program that dlopen() and use the real module. The communication between the two components is via a UNIX socket. pkcs11-gateway is based on the rpc-layer of Gnome Keyring. - Alex Dupre ale@FreeBSD.org
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pkcs11-gateway/Makefile38
-rw-r--r--security/pkcs11-gateway/distinfo2
-rw-r--r--security/pkcs11-gateway/pkg-descr9
4 files changed, 50 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 620d528093d9..0dd5bbbebe30 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -661,6 +661,7 @@
SUBDIR += pinentry-qt4
SUBDIR += pkcrack
SUBDIR += pkcs11-dump
+ SUBDIR += pkcs11-gateway
SUBDIR += pkcs11-helper
SUBDIR += pks
SUBDIR += pktsuckers
diff --git a/security/pkcs11-gateway/Makefile b/security/pkcs11-gateway/Makefile
new file mode 100644
index 000000000000..2fed029fc04f
--- /dev/null
+++ b/security/pkcs11-gateway/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: pkcs11-gateway
+# Date created: 1 Apr 2011
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pkcs11-gateway
+PORTVERSION= 1.0
+CATEGORIES= security devel linux
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= ale
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A wrapper Cryptoki library to use Linux PKCS\#11 modules
+
+LICENSE= LGPL20
+
+MAKEFILE= Makefile.FreeBSD
+USE_LDCONFIG= yes
+USE_LINUX= yes
+
+PLIST_FILES= bin/pkcs11-gateway lib/libpkcs11-gateway.so \
+ lib/libpkcs11-gateway.so.1
+
+PORTDOCS= README
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pkcs11-gateway ${PREFIX}/bin/
+ ${INSTALL_LIB} ${WRKSRC}/libpkcs11-gateway.so.1 ${PREFIX}/lib/
+ cd ${PREFIX}/lib && ${LN} -sf libpkcs11-gateway.so.1 \
+ libpkcs11-gateway.so
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/pkcs11-gateway/distinfo b/security/pkcs11-gateway/distinfo
new file mode 100644
index 000000000000..6d90f2590ee9
--- /dev/null
+++ b/security/pkcs11-gateway/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pkcs11-gateway-1.0.tar.gz) = d8eb5931aa3faf9e68c1e8d0dbe8f4e7e7362b0bc48bf0d61de9f89c42428260
+SIZE (pkcs11-gateway-1.0.tar.gz) = 68482
diff --git a/security/pkcs11-gateway/pkg-descr b/security/pkcs11-gateway/pkg-descr
new file mode 100644
index 000000000000..5587afb96496
--- /dev/null
+++ b/security/pkcs11-gateway/pkg-descr
@@ -0,0 +1,9 @@
+pkcs11-gateway is a software that allows you to use a Linux 32-bit PKCS#11
+module on FreeBSD i386/amd64.
+It consists of a FreeBSD Cryptoki wrapper library that serializes and forwards
+PKCS#11 function calls to a Linux server program that dlopen() and use the
+real module. The communication between the two components is via a UNIX socket.
+pkcs11-gateway is based on the rpc-layer of Gnome Keyring.
+
+- Alex Dupre
+ale@FreeBSD.org