aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2015-11-12 02:42:24 +0800
committerdinoex <dinoex@FreeBSD.org>2015-11-12 02:42:24 +0800
commite44034ca80a4d0d51dd7efd628697f1e090579fa (patch)
treeb4d60e6488b8708bf86ed18c0dab653bf107ece7 /security
parentf22908ae80e01f43d45fb4385429e151a522bf56 (diff)
downloadfreebsd-ports-gnome-e44034ca80a4d0d51dd7efd628697f1e090579fa.tar.gz
freebsd-ports-gnome-e44034ca80a4d0d51dd7efd628697f1e090579fa.tar.zst
freebsd-ports-gnome-e44034ca80a4d0d51dd7efd628697f1e090579fa.zip
This is a fast and Secure Tunnelling Daemon.
WWW: http://git.universe-factory.net/fastd PR: 204473 Submitted by: Jan Bramkamp
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/fastd-devel/Makefile33
-rw-r--r--security/fastd-devel/distinfo2
-rw-r--r--security/fastd-devel/files/fastd_devel.in75
-rw-r--r--security/fastd-devel/files/patch-src_CMakeLists.txt10
-rw-r--r--security/fastd-devel/pkg-descr3
6 files changed, 124 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 29bc2add9186..cc10dbdd67be 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -123,6 +123,7 @@
SUBDIR += fakeident
SUBDIR += fakeroot
SUBDIR += fastd
+ SUBDIR += fastd-devel
SUBDIR += fbopenssl
SUBDIR += fcheck
SUBDIR += fcrackzip
diff --git a/security/fastd-devel/Makefile b/security/fastd-devel/Makefile
new file mode 100644
index 000000000000..b6972ec53ad9
--- /dev/null
+++ b/security/fastd-devel/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= fastd
+PORTVERSION= 18.a.20151111
+CATEGORIES= security net
+MASTER_SITES= http://git.universe-factory.net/fastd/snapshot/
+PKGNAMESUFFIX= -devel
+DISTNAME= 999b87b80302dbc14e23ef3dff187b91dae7fab5
+
+MAINTAINER= crest_maintainer@rlwinm.de
+COMMENT= Fast and Secure Tunnelling Daemon
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+LIB_DEPENDS= libjson-c.so:${PORTSDIR}/devel/json-c \
+ libsodium.so:${PORTSDIR}/security/libsodium \
+ libuecc.so:${PORTSDIR}/security/libuecc
+
+USES= bison cmake:outsource pkgconfig tar
+
+PKG_CONFIG_PATH= ${PREFIX}/lib/pkgconfig/
+CONFIGURE_ENV+= PKG_CONFIG_PATH=${PKG_CONFIG_PATH}
+
+USE_RC_SUBR= fastd_devel
+
+PLIST_FILES= bin/fastd-devel \
+ man/man1/fastd-devel.1.gz
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/fastd.1 ${STAGEDIR}${PREFIX}/man/man1/fastd-devel.1
+
+.include <bsd.port.mk>
diff --git a/security/fastd-devel/distinfo b/security/fastd-devel/distinfo
new file mode 100644
index 000000000000..459749b553f0
--- /dev/null
+++ b/security/fastd-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (999b87b80302dbc14e23ef3dff187b91dae7fab5.tar) = 4267521d02e6f4772e9d234a37e40d8af1c63f31493cf93460b25f21df219005
+SIZE (999b87b80302dbc14e23ef3dff187b91dae7fab5.tar) = 1484800
diff --git a/security/fastd-devel/files/fastd_devel.in b/security/fastd-devel/files/fastd_devel.in
new file mode 100644
index 000000000000..77bb9f5137ab
--- /dev/null
+++ b/security/fastd-devel/files/fastd_devel.in
@@ -0,0 +1,75 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+# PROVIDE: fastd_devel
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+
+# -----------------------------------------------------------------------------
+#
+# This script supports running multiple instances of fastd.
+# To run additional instances link this script to something like
+# % ln -s fastd fastd_foo
+# and define additional fastd_foo_* variables in one of
+# /etc/rc.conf, /etc/rc.conf.local or /etc/rc.conf.d/fastd_foo
+#
+# Below NAME should be substituted with the name of this script. By default
+# it is fastd, so read as fastd_enable. If you linked the script to
+# fastd_foo, then read as fastd_foo_enable etc.
+#
+# The following variables are supported (defaults are shown).
+# You can place them in any of
+# /etc/rc.conf, /etc/rc.conf.local or /etc/rc.conf.d/NAME
+#
+# NAME_enable="NO" # set to YES to enable fastd
+#
+# # optional:
+# NAME_configfile="%%PREFIX%%/etc/fastd/NAME.conf" # --config file
+#
+
+. /etc/rc.subr
+
+case "$0" in
+/etc/rc*)
+ # during boot (shutdown) $0 is /etc/rc (/etc/rc.shutdown),
+ # so get the name of the script from $_file
+ name="$_file"
+ ;;
+*)
+ name="$0"
+ ;;
+esac
+
+name="${name##*/}"
+rcvar=${name}_enable
+
+clean_pidfile()
+{
+ rm -f "$pidfile" || warn "Could not remove $pidfile."
+}
+
+# reload: support SIGHUP to reload peer directories
+extra_commands="reload"
+
+# pidfile
+pidfile="/var/run/${name}.pid"
+
+# run this last
+start_precmd="clean_pidfile"
+stop_postcmd="clean_pidfile"
+
+load_rc_config ${name}
+
+eval ": \${${name}_enable:=\"NO\"}"
+eval ": \${${name}_configfile:=\"%%PREFIX%%/etc/fastd/${name}.conf\"}"
+
+configfile="$(eval echo \${${name}_configfile})"
+
+required_files=${configfile}
+
+# command and arguments
+command="%%PREFIX%%/bin/fastd-devel"
+command_args="--daemon --config ${configfile} --pid-file ${pidfile}"
+
+run_rc_command "$1"
diff --git a/security/fastd-devel/files/patch-src_CMakeLists.txt b/security/fastd-devel/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..3b4f846d914e
--- /dev/null
+++ b/security/fastd-devel/files/patch-src_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- src/CMakeLists.txt.orig 2015-11-11 18:08:50 UTC
++++ src/CMakeLists.txt
+@@ -45,6 +45,7 @@ add_executable(fastd
+ )
+ set_property(TARGET fastd PROPERTY COMPILE_FLAGS "${FASTD_CFLAGS}")
+ set_property(TARGET fastd PROPERTY LINK_FLAGS "${PTHREAD_LDFLAGS} ${LIBUECC_LDFLAGS_OTHER} ${NACL_LDFLAGS_OTHER} ${JSON_C_LDFLAGS_OTHER} ${LDFLAGS_LTO}")
++set_property(TARGET fastd PROPERTY SUFFIX "-devel")
+ set_property(TARGET fastd APPEND PROPERTY INCLUDE_DIRECTORIES ${LIBCAP_INCLUDE_DIR} ${NACL_INCLUDE_DIR} ${JSON_C_INCLUDE_DIR})
+ target_link_libraries(fastd protocols methods ciphers macs ${RT_LIBRARY} ${LIBCAP_LIBRARY} ${LIBUECC_LIBRARIES} ${NACL_LIBRARIES} ${OPENSSL_CRYPTO_LIBRARY} ${JSON_C_LIBRARIES})
+
diff --git a/security/fastd-devel/pkg-descr b/security/fastd-devel/pkg-descr
new file mode 100644
index 000000000000..eddb9e4a0c08
--- /dev/null
+++ b/security/fastd-devel/pkg-descr
@@ -0,0 +1,3 @@
+This is a fast and Secure Tunnelling Daemon.
+
+WWW: http://git.universe-factory.net/fastd