aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-14 01:17:27 +0800
committermarino <marino@FreeBSD.org>2016-09-14 01:17:27 +0800
commite5e58f5b7b82099348c7548860311488670ed3cb (patch)
tree659a96cad6be22c045021c6bc8077fe8e98f6ac2 /security
parent0b39b960cd75668248b6c1f43a092bff074776f4 (diff)
downloadfreebsd-ports-gnome-e5e58f5b7b82099348c7548860311488670ed3cb.tar.gz
freebsd-ports-gnome-e5e58f5b7b82099348c7548860311488670ed3cb.tar.zst
freebsd-ports-gnome-e5e58f5b7b82099348c7548860311488670ed3cb.zip
security/hydra: Configure for any SSL base and IGNORE LibreSSL
Several symbols including RSA_get0_key are unreferenced while linking with LibreSSL so IGNORE this port if SSL_DEFAULT matches "libressl". Approved by: SSL blanket
Diffstat (limited to 'security')
-rw-r--r--security/hydra/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/security/hydra/Makefile b/security/hydra/Makefile
index fb795afa185a..97a0444ef5bf 100644
--- a/security/hydra/Makefile
+++ b/security/hydra/Makefile
@@ -23,6 +23,8 @@ PLIST_FILES= bin/hydra bin/pw-inspector bin/dpl4hydra.sh bin/hydra-wizard.sh \
man/man1/hydra.1.gz man/man1/pw-inspector.1.gz
GNU_CONFIGURE= yes
USES= gmake localbase ssl
+CONFIGURE_ARGS= --with-ssl=${OPENSSLINC} \
+ --with-ssl-lib=${OPENSSLLIB}
OPTIONS_DEFINE= FIREBIRD SSH SVN X11
OPTIONS_DEFAULT=SSH
@@ -36,6 +38,12 @@ X11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
X11_USE= gnome=atk,cairo,gdkpixbuf2,glib20,gtk20,pango
X11_PLIST_FILES= bin/xhydra man/man1/xhydra.1.gz
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT:Mlibressl*}
+IGNORE= Detected LibreSSL (missing RSA_get0_key and others)
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|CC=gcc||; s|-O3|${CFLAGS}|;' \
@@ -52,4 +60,4 @@ post-install-X11-on:
${INSTALL_PROGRAM} ${WRKSRC}/hydra-gtk/src/xhydra ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xhydra.1 ${STAGEDIR}${MANPREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>