aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-17 22:06:58 +0800
committererwin <erwin@FreeBSD.org>2005-12-17 22:06:58 +0800
commite75beac9cfe9f3db769b562336835049b5e478be (patch)
tree538a859080b5e0b0a0f03a4405efcb8f077ae2eb /security
parentad0c08fcc07a196eda0303ea9d97cc56bdb4ea2a (diff)
downloadfreebsd-ports-gnome-e75beac9cfe9f3db769b562336835049b5e478be.tar.gz
freebsd-ports-gnome-e75beac9cfe9f3db769b562336835049b5e478be.tar.zst
freebsd-ports-gnome-e75beac9cfe9f3db769b562336835049b5e478be.zip
The Digest::CRC module calculates CRC sums of all sorts. It contains wrapper
functions with the correct parameters for CRC-CCITT, CRC-16 and CRC-32. WWW: http://search.cpan.org/dist/Digest-CRC PR: ports/90546 Submitted by: Gabor Kovesdan
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Digest-CRC/Makefile24
-rw-r--r--security/p5-Digest-CRC/distinfo3
-rw-r--r--security/p5-Digest-CRC/pkg-descr4
-rw-r--r--security/p5-Digest-CRC/pkg-plist7
5 files changed, 39 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 2d0a2490f049..72c550213940 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -331,6 +331,7 @@
SUBDIR += p5-Digest
SUBDIR += p5-Digest-Adler32
SUBDIR += p5-Digest-BubbleBabble
+ SUBDIR += p5-Digest-CRC
SUBDIR += p5-Digest-HMAC
SUBDIR += p5-Digest-Haval256
SUBDIR += p5-Digest-MD2
diff --git a/security/p5-Digest-CRC/Makefile b/security/p5-Digest-CRC/Makefile
new file mode 100644
index 000000000000..2a8ded1bac9a
--- /dev/null
+++ b/security/p5-Digest-CRC/Makefile
@@ -0,0 +1,24 @@
+# Ports collection Makefile for: p5-Digest-CRC
+# Date created: 17 Dec 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Digest-CRC
+PORTVERSION= 0.09
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for calculating CRC cheksums
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::CRC.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Digest-CRC/distinfo b/security/p5-Digest-CRC/distinfo
new file mode 100644
index 000000000000..e5de8459eca9
--- /dev/null
+++ b/security/p5-Digest-CRC/distinfo
@@ -0,0 +1,3 @@
+MD5 (Digest-CRC-0.09.tar.gz) = 1456ba664d59a7ccc7d30e980f1695d0
+SHA256 (Digest-CRC-0.09.tar.gz) = f73f1b76f091a509a3fa8146a44c536c03af10a381f28a69840a243d6f99974d
+SIZE (Digest-CRC-0.09.tar.gz) = 5914
diff --git a/security/p5-Digest-CRC/pkg-descr b/security/p5-Digest-CRC/pkg-descr
new file mode 100644
index 000000000000..d0c6604e8273
--- /dev/null
+++ b/security/p5-Digest-CRC/pkg-descr
@@ -0,0 +1,4 @@
+The Digest::CRC module calculates CRC sums of all sorts. It contains wrapper
+functions with the correct parameters for CRC-CCITT, CRC-16 and CRC-32.
+
+WWW: http://search.cpan.org/dist/Digest-CRC
diff --git a/security/p5-Digest-CRC/pkg-plist b/security/p5-Digest-CRC/pkg-plist
new file mode 100644
index 000000000000..8d3a1a1d8ad3
--- /dev/null
+++ b/security/p5-Digest-CRC/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Digest/CRC.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/CRC/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/CRC/CRC.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/CRC/CRC.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/CRC
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Digest/ 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/ 2>/dev/null || true