aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2015-09-26 20:37:43 +0800
committerpi <pi@FreeBSD.org>2015-09-26 20:37:43 +0800
commitf28e3e18da8d5564d6658a3869a82ad31190022b (patch)
treeab20e2224b9d8c524ddb1025402a4ac145820be6 /security
parente0507ceabf28887e25d2d8e49eac5380bef9a7fa (diff)
downloadfreebsd-ports-gnome-f28e3e18da8d5564d6658a3869a82ad31190022b.tar.gz
freebsd-ports-gnome-f28e3e18da8d5564d6658a3869a82ad31190022b.tar.zst
freebsd-ports-gnome-f28e3e18da8d5564d6658a3869a82ad31190022b.zip
New port: security/py-acme
Implements the Automated Certificate Management Environment (ACME) WWW: https://github.com/letsencrypt/letsencrypt/tree/master/acme PR: 203364 Submitted by: Carlos J Puga Medina <cpm@fbsd.es>, pi
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-acme/Makefile33
-rw-r--r--security/py-acme/distinfo2
-rw-r--r--security/py-acme/pkg-descr3
4 files changed, 39 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3b79c3d5b444..df4e04a8cfe9 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -785,6 +785,7 @@
SUBDIR += py-Products.PluggableAuthService
SUBDIR += py-RestrictedPython
SUBDIR += py-SecretStorage
+ SUBDIR += py-acme
SUBDIR += py-artifacts
SUBDIR += py-bcrypt
SUBDIR += py-borg.localrole
diff --git a/security/py-acme/Makefile b/security/py-acme/Makefile
new file mode 100644
index 000000000000..e121955e5f7c
--- /dev/null
+++ b/security/py-acme/Makefile
@@ -0,0 +1,33 @@
+# Created by: Carlos J Puga Medina <cpm@fbsd.es>
+# $FreeBSD$
+
+PORTNAME= acme
+PORTVERSION= 0.0.b1
+CATEGORIES= security python
+
+MAINTAINER= cpm@fbsd.es
+COMMENT= ACME implementation
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>0:${PORTSDIR}/devel/py-asn1 \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>=0.8:${PORTSDIR}/security/py-cryptography \
+ ${PYTHON_PKGNAMEPREFIX}mock>=1.0.1:${PORTSDIR}/devel/py-mock \
+ ${PYTHON_PKGNAMEPREFIX}ndg_httpsclient>=0.4.0:${PORTSDIR}/net/py-ndg_httpsclient \
+ ${PYTHON_PKGNAMEPREFIX}pyrfc3339>=0.2:${PORTSDIR}/devel/py-pyrfc3339 \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=2015.4:${PORTSDIR}/devel/py-pytz \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}werkzeug>=0.9:${PORTSDIR}/www/py-werkzeug
+
+USES= gmake python
+USE_PYTHON= autoplist distutils
+
+WRKSRC= ${WRKDIR}/letsencrypt-22260a8/acme
+
+USE_GITHUB= yes
+GH_ACCOUNT= letsencrypt
+GH_PROJECT= letsencrypt
+GH_TAGNAME= 22260a8
+
+.include <bsd.port.mk>
diff --git a/security/py-acme/distinfo b/security/py-acme/distinfo
new file mode 100644
index 000000000000..f481817b9fe9
--- /dev/null
+++ b/security/py-acme/distinfo
@@ -0,0 +1,2 @@
+SHA256 (letsencrypt-letsencrypt-0.0.b1-22260a8_GH0.tar.gz) = 510e19965ff425d6dd46abb988da77bb41df3a9d6532fc71a36c380498c0584d
+SIZE (letsencrypt-letsencrypt-0.0.b1-22260a8_GH0.tar.gz) = 317170
diff --git a/security/py-acme/pkg-descr b/security/py-acme/pkg-descr
new file mode 100644
index 000000000000..938f138fa313
--- /dev/null
+++ b/security/py-acme/pkg-descr
@@ -0,0 +1,3 @@
+Implements the Automated Certificate Management Environment (ACME)
+
+WWW: https://github.com/letsencrypt/letsencrypt/tree/master/acme