aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-04-11 17:21:38 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-04-11 17:21:38 +0800
commit0567e8fe079e8a7b5ec11662b1384fce6af8355c (patch)
tree95f34fbd4f74537f61924aabafeaf1c194639fe6 /security
parentf0004d6e9c9c71c87f61fcbdc05355475fa95be1 (diff)
downloadfreebsd-ports-gnome-0567e8fe079e8a7b5ec11662b1384fce6af8355c.tar.gz
freebsd-ports-gnome-0567e8fe079e8a7b5ec11662b1384fce6af8355c.tar.zst
freebsd-ports-gnome-0567e8fe079e8a7b5ec11662b1384fce6af8355c.zip
- Convert to new options framework
- Use USES=gmake - Support STAGEDIR - Simplify Makefile
Diffstat (limited to 'security')
-rw-r--r--security/p5-openxpki-client-html-mason/Makefile31
-rw-r--r--security/p5-openxpki-client-html-mason/pkg-plist5
2 files changed, 14 insertions, 22 deletions
diff --git a/security/p5-openxpki-client-html-mason/Makefile b/security/p5-openxpki-client-html-mason/Makefile
index 55004ddce78b..623f84f5a8c8 100644
--- a/security/p5-openxpki-client-html-mason/Makefile
+++ b/security/p5-openxpki-client-html-mason/Makefile
@@ -12,27 +12,20 @@ DIST_SUBDIR= openxpki
MAINTAINER= svysh.fbsd@gmail.com
COMMENT= Web interface for local openxpki daemon
-BROKEN= not staged
+OPTIONS_DEFINE= DOCS EXAMPLES
+
BUILD_DEPENDS= \
p5-openxpki-client>=0:${PORTSDIR}/security/p5-openxpki-client \
p5-HTML-Mason>=0:${PORTSDIR}/www/p5-HTML-Mason \
p5-Data-SpreadPagination>=0:${PORTSDIR}/textproc/p5-Data-SpreadPagination
RUN_DEPENDS:= ${BUILD_DEPENDS}
-MAN3= OpenXPKI::Client::HTML::Mason.3 \
- OpenXPKI::Client::HTML::Mason::CRR.3 \
- OpenXPKI::Client::HTML::Mason::Config.3 \
- OpenXPKI::Client::HTML::Mason::Javascript.3 \
- OpenXPKI::Client::HTML::Mason::Menu.3
-USE_GMAKE= yes
-USES= perl5
+USES= gmake perl5
USE_PERL5= configure
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- @${CP} -R ${WRKSRC}/htdocs ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${CP} -R ${WRKSRC}/htdocs ${STAGEDIR}${DOCSDIR}/
@${ECHO_MSG} ""
@${ECHO_MSG} "==================================================================="
@${ECHO_MSG} "===> Mason htdocs for ${DISTNAME}"
@@ -42,10 +35,8 @@ post-install:
.if !defined(BATCH)
@sleep 3
.endif
-.endif
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- @${CP} -R ${WRKSRC}/eg ${EXAMPLESDIR}/
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/eg ${STAGEDIR}${EXAMPLESDIR}/
@${ECHO_MSG} ""
@${ECHO_MSG} "==================================================================="
@${ECHO_MSG} "===> Examples of simple Mason configuration via httpd.conf directives"
@@ -55,11 +46,8 @@ post-install:
.if !defined(BATCH)
@sleep 3
.endif
-.endif
-.if !defined(NOPORTDATA)
- ${MKDIR} ${DATADIR}
- @${MKDIR} ${DATADIR}
- @${CP} -R ${WRKSRC}/bin ${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${CP} -R ${WRKSRC}/bin ${STAGEDIR}${DATADIR}/
@${ECHO_MSG} ""
@${ECHO_MSG} "==================================================================="
@${ECHO_MSG} "===> Examples of CGI scripts for ${DISTNAME}"
@@ -69,6 +57,5 @@ post-install:
.if !defined(BATCH)
@sleep 3
.endif
-.endif
.include <bsd.port.mk>
diff --git a/security/p5-openxpki-client-html-mason/pkg-plist b/security/p5-openxpki-client-html-mason/pkg-plist
index 7448f97981d3..8faef28a6079 100644
--- a/security/p5-openxpki-client-html-mason/pkg-plist
+++ b/security/p5-openxpki-client-html-mason/pkg-plist
@@ -5,6 +5,11 @@
%%SITE_PERL%%/OpenXPKI/Client/HTML/Mason/Javascript.pm
%%SITE_PERL%%/OpenXPKI/Client/HTML/Mason/Menu.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI/Client/HTML/Mason/.packlist
+%%PERL5_MAN3%%/OpenXPKI::Client::HTML::Mason.3.gz
+%%PERL5_MAN3%%/OpenXPKI::Client::HTML::Mason::CRR.3.gz
+%%PERL5_MAN3%%/OpenXPKI::Client::HTML::Mason::Config.3.gz
+%%PERL5_MAN3%%/OpenXPKI::Client::HTML::Mason::Javascript.3.gz
+%%PERL5_MAN3%%/OpenXPKI::Client::HTML::Mason::Menu.3.gz
%%PORTDOCS%%%%DOCSDIR%%/htdocs/Menu/Query/index.html
%%PORTDOCS%%%%DOCSDIR%%/htdocs/Renderer/Command/default.mhtml
%%PORTDOCS%%%%DOCSDIR%%/htdocs/Renderer/Service/GET_AUTHENTICATION_STACK.mhtml