aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2014-04-11 05:46:30 +0800
committerzi <zi@FreeBSD.org>2014-04-11 05:46:30 +0800
commit609441b5d3cd2036fa213a1d6e7379ed9503b172 (patch)
tree1d725df17d55a3fa648b9e315289842335364fd5 /security
parentf4eaa1ee5b438c69bde1db3f57380f83ad9bac94 (diff)
downloadfreebsd-ports-gnome-609441b5d3cd2036fa213a1d6e7379ed9503b172.tar.gz
freebsd-ports-gnome-609441b5d3cd2036fa213a1d6e7379ed9503b172.tar.zst
freebsd-ports-gnome-609441b5d3cd2036fa213a1d6e7379ed9503b172.zip
- Add 'USES=shebangfix' to fix perl path of 'stunnel3' script
- Strip shared library - Bump PORTREVISION PR: ports/188418 Submitted by: Yasuhiro KIMURA <yasu@utahime.org>
Diffstat (limited to 'security')
-rw-r--r--security/stunnel/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index c903b9cea558..065e22202530 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= stunnel
PORTVERSION= 5.01
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://www.stunnel.org/downloads/%SUBDIR%/ \
http://mirrors.zerg.biz/stunnel/%SUBDIR%/ \
@@ -25,12 +26,14 @@ COMMENT= SSL encryption wrapper for standard network daemons
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
+USES= shebangfix
USE_AUTOTOOLS= libtool
USE_RC_SUBR= stunnel
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var/tmp --enable-static
+SHEBANG_FILES= src/stunnel3.in
OPTIONS_DEFINE= IPV6 LIBWRAP SSL_PORT FIPS
OPTIONS_SINGLE= THREAD
@@ -102,6 +105,9 @@ post-patch:
@${REINPLACE_CMD} -E -e 's|\$$\(docdir\)/examples|${EXAMPLESDIR}|g' ${WRKSRC}/tools/Makefile.in
.endif
+post-build:
+ @${STRIP_CMD} ${WRKSRC}/src/.libs/libstunnel.so
+
cert:
@${ECHO} ""
@${ECHO} "**************************************************************************"