aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2014-04-23 22:24:13 +0800
committergarga <garga@FreeBSD.org>2014-04-23 22:24:13 +0800
commit84b9471bb63e2fd7626f2250878ffbe90f8b2fff (patch)
tree993c6d336bb43a4c743b7a138f7dafc73f8c4220 /security
parent6694195844c85b02ced4c3c9ab62ce9573081c65 (diff)
downloadfreebsd-ports-gnome-84b9471bb63e2fd7626f2250878ffbe90f8b2fff.tar.gz
freebsd-ports-gnome-84b9471bb63e2fd7626f2250878ffbe90f8b2fff.tar.zst
freebsd-ports-gnome-84b9471bb63e2fd7626f2250878ffbe90f8b2fff.zip
Fix build with clang:
. Add direct dependency to net/bpf.h . Rename symbol csin to avoid conflict with complex.h Approved by: portmgr (blanket)
Diffstat (limited to 'security')
-rw-r--r--security/dsniff/Makefile3
-rw-r--r--security/dsniff/files/patch-pcaputil.c3
2 files changed, 5 insertions, 1 deletions
diff --git a/security/dsniff/Makefile b/security/dsniff/Makefile
index 3589c09f51a1..ec3a6708c0f1 100644
--- a/security/dsniff/Makefile
+++ b/security/dsniff/Makefile
@@ -55,6 +55,9 @@ post-patch:
s|(LNETINC=).*|\1${LIBNET_INC}|; \
s|(LNETLIB=).*|\1${LIBNET_LIB}|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's,csin,_csin,g' \
+ ${WRKSRC}/webmitm.c \
+ ${WRKSRC}/sshmitm.c
.if !empty(LIBNIDS_GLIB2)
pre-configure:
diff --git a/security/dsniff/files/patch-pcaputil.c b/security/dsniff/files/patch-pcaputil.c
index c8cc52011716..654e90a77162 100644
--- a/security/dsniff/files/patch-pcaputil.c
+++ b/security/dsniff/files/patch-pcaputil.c
@@ -1,10 +1,11 @@
--- ./pcaputil.c.orig Tue Nov 14 12:51:08 2000
+++ ./pcaputil.c Mon Sep 25 16:26:13 2006
-@@ -13,9 +13,9 @@
+@@ -13,9 +13,10 @@
#include <stdlib.h>
#include <string.h>
#include <err.h>
-#include <pcap.h>
++#include <net/bpf.h>
+#include </usr/include/pcap.h>
#ifdef BSD
-#include <pcap-int.h>