aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjedgar <jedgar@FreeBSD.org>2000-12-19 19:35:15 +0800
committerjedgar <jedgar@FreeBSD.org>2000-12-19 19:35:15 +0800
commite434eec16e3523b3a53416c1c7abd1499be3344f (patch)
tree726970c1dcc47fe519bb6c1155f2053de027bcae /security
parent5357937c740c2fcc7e4c157a61cde3480136d0e9 (diff)
downloadfreebsd-ports-gnome-e434eec16e3523b3a53416c1c7abd1499be3344f.tar.gz
freebsd-ports-gnome-e434eec16e3523b3a53416c1c7abd1499be3344f.tar.zst
freebsd-ports-gnome-e434eec16e3523b3a53416c1c7abd1499be3344f.zip
Use mktemp(1) to create a temporary file instead of using a short
guessable filename during configuration. Approved by: Maintainer
Diffstat (limited to 'security')
-rw-r--r--security/cyrus-sasl/scripts/configure.sasl10
-rw-r--r--security/cyrus-sasl2/scripts/configure.sasl10
2 files changed, 12 insertions, 8 deletions
diff --git a/security/cyrus-sasl/scripts/configure.sasl b/security/cyrus-sasl/scripts/configure.sasl
index 40e33f3c69a3..76337a140d0e 100644
--- a/security/cyrus-sasl/scripts/configure.sasl
+++ b/security/cyrus-sasl/scripts/configure.sasl
@@ -5,6 +5,8 @@ if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
fi
+tempfile=`mktemp -t checklist`
+
if [ "${BATCH}" ]; then
if [ "x${ENABLE_DB3}" = "xYES" ]; then
OPTIONS=\"DB3\"
@@ -43,14 +45,14 @@ Please select desired options:" -1 -1 16 \
DB3 "Berkeley DB package, revision 3" ${SET_DB3} \
MySQL "MySQL password Authentication" ${SET_MYSQL} \
OpenLDAP "OpenLDAP password Authentication" ${SET_LDAP} \
-2> /tmp/checklist.tmp.$$
+2> $tempfile
retval=$?
- if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
+ if [ -s $tempfile ]; then
+ set `cat $tempfile`
fi
- rm -f /tmp/checklist.tmp.$$
+ rm -f $tempfile
case $retval in
0) if [ -z "$*" ]; then
diff --git a/security/cyrus-sasl2/scripts/configure.sasl b/security/cyrus-sasl2/scripts/configure.sasl
index 40e33f3c69a3..76337a140d0e 100644
--- a/security/cyrus-sasl2/scripts/configure.sasl
+++ b/security/cyrus-sasl2/scripts/configure.sasl
@@ -5,6 +5,8 @@ if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
fi
+tempfile=`mktemp -t checklist`
+
if [ "${BATCH}" ]; then
if [ "x${ENABLE_DB3}" = "xYES" ]; then
OPTIONS=\"DB3\"
@@ -43,14 +45,14 @@ Please select desired options:" -1 -1 16 \
DB3 "Berkeley DB package, revision 3" ${SET_DB3} \
MySQL "MySQL password Authentication" ${SET_MYSQL} \
OpenLDAP "OpenLDAP password Authentication" ${SET_LDAP} \
-2> /tmp/checklist.tmp.$$
+2> $tempfile
retval=$?
- if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
+ if [ -s $tempfile ]; then
+ set `cat $tempfile`
fi
- rm -f /tmp/checklist.tmp.$$
+ rm -f $tempfile
case $retval in
0) if [ -z "$*" ]; then