aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-07-16 14:30:29 +0800
committerjgh <jgh@FreeBSD.org>2013-07-16 14:30:29 +0800
commit0e5ca134db5acaa54d247fc6bea75dd901f74d90 (patch)
treee37a0bb6249a498aeede24c24e6ce2661b762566 /security
parent2999174d1f5856084e917e44be862cd5b4ef67bb (diff)
downloadfreebsd-ports-gnome-0e5ca134db5acaa54d247fc6bea75dd901f74d90.tar.gz
freebsd-ports-gnome-0e5ca134db5acaa54d247fc6bea75dd901f74d90.tar.zst
freebsd-ports-gnome-0e5ca134db5acaa54d247fc6bea75dd901f74d90.zip
Orthrus is a C library and user interfaces for RFC 2289,
"A One-Time Password System (OTP)", also known as OPIE or S/Key. WWW: http://code.google.com/p/orthrus PR: ports/180571 Submitted by: gavin@16degrees.com.au
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/orthrus/Makefile37
-rw-r--r--security/orthrus/distinfo2
-rw-r--r--security/orthrus/pkg-descr4
-rw-r--r--security/orthrus/pkg-message9
-rw-r--r--security/orthrus/pkg-plist11
6 files changed, 64 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 176dc6d14422..cabefaf1e4d1 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -376,6 +376,7 @@
SUBDIR += openvpn22
SUBDIR += ophcrack
SUBDIR += opieprint
+ SUBDIR += orthrus
SUBDIR += osiris
SUBDIR += ossec-hids-client
SUBDIR += ossec-hids-local
diff --git a/security/orthrus/Makefile b/security/orthrus/Makefile
new file mode 100644
index 000000000000..22ee0375adf2
--- /dev/null
+++ b/security/orthrus/Makefile
@@ -0,0 +1,37 @@
+# Created by: Gavin McDonald <gavin@16degrees.com.au>
+# $FreeBSD$
+
+PORTNAME= orthrus
+PORTVERSION= 0.8.0
+CATEGORIES= security
+MASTER_SITES= GOOGLE_CODE \
+ http://16degrees.com.au/${PORTNAME}/
+
+MAINTAINER= gavin@16degrees.com.au
+COMMENT= One-Time Password System (OTP) alternative to OPIE or S/Key
+
+LICENSE= AL2
+
+LIB_DEPENDS= apr-1:${PORTSDIR}/devel/apr1
+
+USE_SCONS= yes
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+USES= iconv
+PORTDOCS= *
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && \
+ ${INSTALL_DATA} NOTICE README TODO ${DOCSDIR})
+.endif
+ ${TOUCH} ${PREFIX}/etc/orthruskeys
+
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/security/orthrus/distinfo b/security/orthrus/distinfo
new file mode 100644
index 000000000000..6054b1f25bd4
--- /dev/null
+++ b/security/orthrus/distinfo
@@ -0,0 +1,2 @@
+SHA256 (orthrus-0.8.0.tar.bz2) = d2148d929b7c38afd5772489a11c21dcab1eebcf0b90c0ecd5d0834ffcf26cb1
+SIZE (orthrus-0.8.0.tar.bz2) = 27285
diff --git a/security/orthrus/pkg-descr b/security/orthrus/pkg-descr
new file mode 100644
index 000000000000..04e55e3276a5
--- /dev/null
+++ b/security/orthrus/pkg-descr
@@ -0,0 +1,4 @@
+Orthrus is a C library and user interfaces for RFC 2289,
+"A One-Time Password System (OTP)", also known as OPIE or S/Key.
+
+WWW: http://code.google.com/p/orthrus
diff --git a/security/orthrus/pkg-message b/security/orthrus/pkg-message
new file mode 100644
index 000000000000..9b2f477a63e8
--- /dev/null
+++ b/security/orthrus/pkg-message
@@ -0,0 +1,9 @@
+Manually edit pam.d/* files as needed and add in the required auth line and
+remove any undesired fallback lines. Also ensure you arent already using opie!"
+
+example in pam.d/system :
+
+auth sufficient pam_orthrus.so
+
+Please remember to delete any such entry BEFORE deinstalling this port or you
+could lock yourself out !!
diff --git a/security/orthrus/pkg-plist b/security/orthrus/pkg-plist
new file mode 100644
index 000000000000..b9d26f450253
--- /dev/null
+++ b/security/orthrus/pkg-plist
@@ -0,0 +1,11 @@
+bin/ortcalc
+bin/ortpasswd
+etc/orthruskeys
+lib/liborthrus-0.so
+lib/security/pam_orthrus.so
+include/orthrus-0/context.h
+include/orthrus-0/orthrus.h
+include/orthrus-0/orthrus_error.h
+include/orthrus-0/orthrus_version.h
+@dirrm include/orthrus-0
+@dirrm lib/security