aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2012-06-24 19:34:51 +0800
committerzi <zi@FreeBSD.org>2012-06-24 19:34:51 +0800
commit3cad1ce73b45bfb0e09d8e93adfc3be9b5c85e07 (patch)
treefe3b9c9888583f8f2c171f93a5d965e03fc4f68b /security
parent3e0876e911ada57cb3888730b11edb7a267cdbaa (diff)
downloadfreebsd-ports-gnome-3cad1ce73b45bfb0e09d8e93adfc3be9b5c85e07.tar.gz
freebsd-ports-gnome-3cad1ce73b45bfb0e09d8e93adfc3be9b5c85e07.tar.zst
freebsd-ports-gnome-3cad1ce73b45bfb0e09d8e93adfc3be9b5c85e07.zip
- Unbreak GnuTLS support for 7.x and 8.x
Diffstat (limited to 'security')
-rw-r--r--security/openconnect/Makefile3
-rw-r--r--security/openconnect/files/patch-gnutls.c11
2 files changed, 11 insertions, 3 deletions
diff --git a/security/openconnect/Makefile b/security/openconnect/Makefile
index 341c32f5f231..d8079fae38e3 100644
--- a/security/openconnect/Makefile
+++ b/security/openconnect/Makefile
@@ -42,9 +42,6 @@ GNUTLS_DESC= Use GnuTLS instead of OpenSSL(EXPERIMENTAL)
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGNUTLS}
-.if ${OSVERSION} < 900007
-BROKEN= GnuTLS support currently requires FreeBSD 9.x or above
-.endif
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+=--with-gnutls
.endif
diff --git a/security/openconnect/files/patch-gnutls.c b/security/openconnect/files/patch-gnutls.c
new file mode 100644
index 000000000000..72e6df0130ac
--- /dev/null
+++ b/security/openconnect/files/patch-gnutls.c
@@ -0,0 +1,11 @@
+--- ./gnutls.c.orig 2012-06-24 07:29:27.000000000 -0400
++++ ./gnutls.c 2012-06-24 07:29:43.000000000 -0400
+@@ -239,7 +239,7 @@
+ /* For systems that don't support O_CLOEXEC, just don't bother.
+ It's not open for long anyway. */
+ #ifndef O_CLOEXEC
+-#define O_CLOEXEC
++#define O_CLOEXEC 0
+ #endif
+
+ static int load_datum(struct openconnect_info *vpninfo,