aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-01-14 19:44:14 +0800
committermiwi <miwi@FreeBSD.org>2008-01-14 19:44:14 +0800
commit4d3ae94a207974789889118a2cb4eeee3018596a (patch)
treec9740f0f5ec1b16b6db60c2e3f5c78add673e63c /security
parent98e03007aaee27218871f31a54c8fc0c5a3e8114 (diff)
downloadfreebsd-ports-gnome-4d3ae94a207974789889118a2cb4eeee3018596a.tar.gz
freebsd-ports-gnome-4d3ae94a207974789889118a2cb4eeee3018596a.tar.zst
freebsd-ports-gnome-4d3ae94a207974789889118a2cb4eeee3018596a.zip
This package provides an object oriented interface to GNU Privacy
Guard (GPG). It requires the GPG executable to be on the system. Though GPG can support symmetric-key cryptography, this package is intended only to facilitate public-key cryptography. WWW: http://pear.php.net/package/Crypt_GPG/
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pear-Crypt_GPG/Makefile25
-rw-r--r--security/pear-Crypt_GPG/distinfo3
-rw-r--r--security/pear-Crypt_GPG/pkg-descr7
4 files changed, 36 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index f67e093fdb30..c07780038541 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -541,6 +541,7 @@
SUBDIR += pear-Crypt_Blowfish
SUBDIR += pear-Crypt_CBC
SUBDIR += pear-Crypt_CHAP
+ SUBDIR += pear-Crypt_GPG
SUBDIR += pear-Crypt_HMAC
SUBDIR += pear-Crypt_RC4
SUBDIR += pear-Crypt_RSA
diff --git a/security/pear-Crypt_GPG/Makefile b/security/pear-Crypt_GPG/Makefile
new file mode 100644
index 000000000000..ee31bb6c03e3
--- /dev/null
+++ b/security/pear-Crypt_GPG/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: pear-Crypt_GPG
+# Date created: 14 Jan 2008
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt_GPG
+PORTVERSION= 0.3.10
+CATEGORIES= security www pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= GNU Privacy Guard (GPG)
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+CATEGORY= Crypt
+FILES= GPG.php GPG/Exceptions.php GPG/Key.php \
+ GPG/Signature.php GPG/Driver/Php.php
+TESTS= PhpDriver.php test.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/security/pear-Crypt_GPG/distinfo b/security/pear-Crypt_GPG/distinfo
new file mode 100644
index 000000000000..b178f86cc8f5
--- /dev/null
+++ b/security/pear-Crypt_GPG/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Crypt_GPG-0.3.10.tgz) = eab7107a1bdcab7b3884c62a3dc0d386
+SHA256 (PEAR/Crypt_GPG-0.3.10.tgz) = d74e687527f07436f18d8a7f174def18c7ba7f7efff8320e63b8c49836e8e875
+SIZE (PEAR/Crypt_GPG-0.3.10.tgz) = 39395
diff --git a/security/pear-Crypt_GPG/pkg-descr b/security/pear-Crypt_GPG/pkg-descr
new file mode 100644
index 000000000000..fe4486c3921b
--- /dev/null
+++ b/security/pear-Crypt_GPG/pkg-descr
@@ -0,0 +1,7 @@
+This package provides an object oriented interface to GNU Privacy
+Guard (GPG). It requires the GPG executable to be on the system.
+
+Though GPG can support symmetric-key cryptography, this package is intended
+only to facilitate public-key cryptography.
+
+WWW: http://pear.php.net/package/Crypt_GPG/